Ticket #543 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

auto-updater should resolve conffile conflicts on -workstation

Reported by: jdreed Owned by:
Priority: normal Milestone: Natty Alpha
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description

This was originally the second half of #483:

Right now, if anything triggers a dpkg conffile conflict, auto-update will hang indefinitely. Cluster machines invoke apttiude with "-o Dpkg::Options::=--force-confnew"

On not-cluster machines, it's less clear. It sounds like Athena 9 used rpm's default behavior, which was the equivalent of --force-confold. I think ideally the update should fail and e-mail root (which may or may not go anywhere useful), leaving them to fix the upgrade, but I don't know if there's a way to make dpkg error out on conffile conflicts.

Change History

comment:1 Changed 4 years ago by jdreed

  • Milestone changed from Summer 2010 (Lucid Deploy) to Fall 2010

comment:2 Changed 4 years ago by jdreed

I vote for --force-confold, with a configurable option in /etc/default/debathena-auto-update to change it to --force-confnew.

I think that best suits the -workstation demographic.

Thoughts?

comment:3 Changed 4 years ago by jdreed

Perhaps the solution to this (and maybe #117) is to come up with a general-purpose way to notify the person sitting at console of a -workstation machine.

It's also been noted that as its invoked currently, auto-update shouldn't hang indefinitely, so we should figure out why it's doing that.

comment:4 Changed 4 years ago by jdreed

  • Status changed from new to committed

comment:5 Changed 3 years ago by jdreed

  • Status changed from committed to development

comment:6 Changed 3 years ago by jdreed

  • Status changed from development to proposed

comment:7 Changed 3 years ago by jdreed

  • Status changed from proposed to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.