Revision 23533,
1.6 KB
checked in by broder, 16 years ago
(diff) |
In debathena-discuss-server, update the logic that configures inetd to
match the athinfod and larvnet packaging.
|
Rev | Line | |
---|
[22699] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for debathena-discuss |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
| 23 | if ! grep -q '^discuss[[:space:]]' /etc/services; then |
---|
| 24 | echo "Discuss 2100/tcp # Networked conferencing." >>/etc/services |
---|
| 25 | fi |
---|
[23533] | 26 | update-inetd --add "discuss\tstream\ttcp\tnowait\tdiscuss\t/usr/sbin/discussd" |
---|
[22699] | 27 | if ! getent passwd discuss >/dev/null; then |
---|
| 28 | adduser --system --no-create-home --disabled-password --home /var/spool/discuss --gecos "Discuss server" --group discuss |
---|
| 29 | fi |
---|
| 30 | if ! dpkg-statoverride --list /usr/sbin/disserve >/dev/null; then |
---|
| 31 | chown discuss:discuss /usr/sbin/disserve |
---|
| 32 | chmod a=rx,u+ws /usr/sbin/disserve |
---|
| 33 | fi |
---|
| 34 | if ! dpkg-statoverride --list /var/spool/discuss >/dev/null; then |
---|
| 35 | chown discuss:discuss /var/spool/discuss |
---|
| 36 | fi |
---|
| 37 | ;; |
---|
| 38 | |
---|
| 39 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 40 | ;; |
---|
| 41 | |
---|
| 42 | *) |
---|
| 43 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 44 | exit 1 |
---|
| 45 | ;; |
---|
| 46 | esac |
---|
| 47 | |
---|
| 48 | # dh_installdeb will replace this with shell code automatically |
---|
| 49 | # generated by other debhelper scripts. |
---|
| 50 | |
---|
| 51 | #DEBHELPER# |
---|
| 52 | |
---|
| 53 | exit 0 |
---|
| 54 | |
---|
| 55 | |
---|
Note: See
TracBrowser
for help on using the repository browser.