source: trunk/athena/bin/discuss/debian/debathena-discuss-server.postinst @ 23531

Revision 23531, 1.7 KB checked in by broder, 16 years ago (diff)
Create the discussd inetd service if upgrading from versions of the package that didn't, not just if the package is being installed for the first time.
Line 
1#!/bin/sh
2# postinst script for debathena-discuss
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if ! grep -q '^discuss[[:space:]]' /etc/services; then
24            echo "Discuss               2100/tcp                        # Networked conferencing." >>/etc/services
25        fi
26        if dpkg --compare-version "$2" lt 10.0.7-0debathena3; then
27            update-inetd --add \
28                'discuss\tstream\ttcp\tnowait\tdiscuss\t/usr/sbin/discussd'
29        fi
30        if ! getent passwd discuss >/dev/null; then
31            adduser --system --no-create-home --disabled-password --home /var/spool/discuss --gecos "Discuss server" --group discuss
32        fi
33        if ! dpkg-statoverride --list /usr/sbin/disserve >/dev/null; then
34            chown discuss:discuss /usr/sbin/disserve
35            chmod a=rx,u+ws /usr/sbin/disserve
36        fi
37        if ! dpkg-statoverride --list /var/spool/discuss >/dev/null; then
38            chown discuss:discuss /var/spool/discuss
39        fi
40    ;;
41
42    abort-upgrade|abort-remove|abort-deconfigure)
43    ;;
44
45    *)
46        echo "postinst called with unknown argument \`$1'" >&2
47        exit 1
48    ;;
49esac
50
51# dh_installdeb will replace this with shell code automatically
52# generated by other debhelper scripts.
53
54#DEBHELPER#
55
56exit 0
57
58
Note: See TracBrowser for help on using the repository browser.