source: trunk/athena/bin/discuss/debian/debathena-discuss.postinst @ 22699

Revision 22699, 1.1 KB checked in by ghudson, 17 years ago (diff)
Snapshot the Debathena materials for Athena packages into "debian" subdirs of the relevant Athena sources, pulling from /mit/debathena/packages/athena. Some big caveats: - Six Debathena packages are excluded because the current Athena 10 project plan does not call for building them: config-console console, dotfiles, glue, olc, and xscreensaver. (dotfiles and glue will be replaced with new Debathena-specific packages.) - Debathena does not cover all Athena packages which are called for to be built; Debian directories for these packages will have to be created. - Some of the packages contain patches, managed by quilt. The plan is to review and apply (or otherwise address) these patches and eliminate them. - The debian/rules files for Debathena packages are designed for use with the result of the athena-tarball script (from /mit/debathena/packages/athena/bin which I don't currently plan to import), and will not work with the raw source directories. The plan here is to write a CDBS extension package containing rules to handle raw Athena source directories, and then modify the rules files appropriately.
Line 
1#!/bin/sh
2# postinst script for debathena-discuss
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        if ! grep -q '^discuss[[:space:]]' /etc/services; then
24            cat <<EOF >>/etc/services
25discuss         2100/tcp                        # Networked conferencing.
26EOF
27        fi
28        ;;
29
30    abort-upgrade|abort-remove|abort-deconfigure)
31        ;;
32
33    *)
34        echo "postinst called with unknown argument \`$1'" >&2
35        exit 1
36    ;;
37esac
38
39# dh_installdeb will replace this with shell code automatically
40# generated by other debhelper scripts.
41
42#DEBHELPER#
43
44exit 0
45
46
Note: See TracBrowser for help on using the repository browser.