Revision 23755,
1.0 KB
checked in by broder, 16 years ago
(diff) |
Revert the last commit for the time being because apparently it
doesn't work as well as I thought.
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_DIVERT_EXTENSION = .debathena |
---|
4 | DEB_DIVERT_FILES_debathena-afs-config += \ |
---|
5 | /etc/openafs/afs.conf.client.debathena \ |
---|
6 | /etc/openafs/CellAlias.debathena \ |
---|
7 | /etc/openafs/CellServDB.debathena \ |
---|
8 | /etc/openafs/SuidCells.debathena \ |
---|
9 | /etc/openafs/ThisCell.debathena \ |
---|
10 | /etc/openafs/cacheinfo.debathena |
---|
11 | DEB_TRANSFORM_FILES_debathena-afs-config += \ |
---|
12 | /etc/openafs/afs.conf.debathena |
---|
13 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
14 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
15 | |
---|
16 | FROM_ATHENA = debian/CellAlias.debathena debian/CellServDB.debathena |
---|
17 | |
---|
18 | clean:: $(FROM_ATHENA) |
---|
19 | common-build-indep:: $(FROM_ATHENA) |
---|
20 | |
---|
21 | $(patsubst %.debathena,%.athena,$(FROM_ATHENA)) : %.athena: FORCE |
---|
22 | wget http://stuff.mit.edu/afs/athena.mit.edu/service/$(patsubst debian/%.athena,%,$@) -O $@.new |
---|
23 | diff -q $@ $@.new # Check that they are the same. |
---|
24 | rm -f $@.new |
---|
25 | |
---|
26 | $(FROM_ATHENA) : %.debathena: %.athena %.debathena-extra |
---|
27 | cat $^ >| $@.tmp |
---|
28 | diff -q $@.tmp $@ || mv $@.tmp $@ |
---|
29 | rm -f $@.tmp |
---|
30 | |
---|
31 | FORCE: |
---|
32 | |
---|
33 | .PRECIOUS: $(patsubst %.debathena,%.athena,$(FROM_ATHENA)) |
---|
Note: See
TracBrowser
for help on using the repository browser.