Revision 24346,
1.1 KB
checked in by broder, 15 years ago
(diff) |
In afs-config:
* Remove the processed CellServDB and CellAlias from version control,
and always generate them at build time. (Because svn always updates
timestamps, the .debathena files were never getting regenerated)
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_DIVERT_EXTENSION = .debathena |
---|
4 | DEB_DIVERT_FILES_debathena-afs-config += \ |
---|
5 | /etc/openafs/afs.conf.client.debathena \ |
---|
6 | /etc/openafs/CellAlias.debathena \ |
---|
7 | /etc/openafs/CellServDB.debathena \ |
---|
8 | /etc/openafs/SuidCells.debathena \ |
---|
9 | /etc/openafs/ThisCell.debathena \ |
---|
10 | /etc/openafs/cacheinfo.debathena |
---|
11 | DEB_TRANSFORM_FILES_debathena-afs-config += \ |
---|
12 | /etc/openafs/afs.conf.debathena |
---|
13 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
14 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
15 | |
---|
16 | FROM_ATHENA = debian/CellAlias.debathena debian/CellServDB.debathena |
---|
17 | ATHENA = $(patsubst %.debathena,%.athena,$(FROM_ATHENA)) |
---|
18 | |
---|
19 | clean:: $(ATHENA) clean-from-athena |
---|
20 | |
---|
21 | clean-from-athena: |
---|
22 | rm -f $(FROM_ATHENA) |
---|
23 | |
---|
24 | common-build-indep:: $(FROM_ATHENA) |
---|
25 | |
---|
26 | $(ATHENA) : %.athena: FORCE |
---|
27 | wget http://stuff.mit.edu/afs/athena.mit.edu/service/$(patsubst debian/%.athena,%,$@) -O $@.new |
---|
28 | diff -q $@ $@.new # Check that they are the same. |
---|
29 | rm -f $@.new |
---|
30 | |
---|
31 | $(FROM_ATHENA) : %.debathena: %.athena %.debathena-extra |
---|
32 | cat $^ >| $@.tmp |
---|
33 | diff -q $@.tmp $@ || mv $@.tmp $@ |
---|
34 | rm -f $@.tmp |
---|
35 | |
---|
36 | FORCE: |
---|
37 | |
---|
38 | .PRECIOUS: $(ATHENA) |
---|
Note: See
TracBrowser
for help on using the repository browser.