1 | #!/bin/sh |
---|
2 | # postinst script for debathena-auto-update |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | desync2cron() { |
---|
21 | hour=$1 |
---|
22 | interval=$2 |
---|
23 | shift 2 |
---|
24 | desync=`desync -n $interval` |
---|
25 | mins=`echo $desync % 60 | bc` |
---|
26 | hours=`echo "$hour + ($desync / 60)" | bc` |
---|
27 | if [ $hours -ge 24 ]; then |
---|
28 | hours=`echo $hours - 24 | bc` |
---|
29 | fi |
---|
30 | echo "$mins $hours * * * $*" |
---|
31 | } |
---|
32 | |
---|
33 | UPD_CRONFILE=/etc/cron.d/athena-auto-update |
---|
34 | UPG_CRONFILE=/etc/cron.d/athena-auto-upgrade |
---|
35 | |
---|
36 | # We stopped shipping our own cron.d file in 1.21, so remove it |
---|
37 | # dpkg-maintscript-helper exists in maverick+ |
---|
38 | if dpkg-maintscript-helper supports rm_conffile 2> /dev/null; then |
---|
39 | dpkg-maintscript-helper rm_conffile \ |
---|
40 | /etc/cron.d/debathena-auto-update 1.22.2 -- "$@" |
---|
41 | else |
---|
42 | # From http://wiki.debian.org/DpkgConffileHandling |
---|
43 | # Which is full of lies, like the fact that postinsts get |
---|
44 | # called with "install" or "upgrade" when they totally don't |
---|
45 | rm_conffile() { |
---|
46 | local PKGNAME="$1" # Unused |
---|
47 | local CONFFILE="$2" |
---|
48 | if [ -f "$CONFFILE".dpkg-del ]; then |
---|
49 | rm -f "$CONFFILE".dpkg-del |
---|
50 | fi |
---|
51 | } |
---|
52 | case "$1" in |
---|
53 | configure) |
---|
54 | if dpkg --compare-versions "$2" le-nl 1.22.2; then |
---|
55 | rm_conffile debathena-auto-update "/etc/cron.d/debathena-auto-update" |
---|
56 | fi |
---|
57 | esac |
---|
58 | fi |
---|
59 | |
---|
60 | case "$1" in |
---|
61 | configure) |
---|
62 | # Nuke /var/lib/athena-update-status on 1.18, |
---|
63 | # since we changed its format. It will be created |
---|
64 | # at the next auto update |
---|
65 | if dpkg --compare-versions "$2" lt 1.18~ && |
---|
66 | [ -f /var/lib/athena-update-status ]; then |
---|
67 | rm /var/lib/athena-update-status |
---|
68 | fi |
---|
69 | |
---|
70 | if [ ! -f /var/lib/athena-update-status ]; then |
---|
71 | echo "$(date +"%s")|$(date +"%s")|ok|Package configured" > /var/lib/athena-update-status |
---|
72 | fi |
---|
73 | |
---|
74 | rm -f $UPD_CRONFILE |
---|
75 | rm -f $UPG_CRONFILE |
---|
76 | |
---|
77 | echo "# Automatically generated by debathena-auto-update postinst" > $UPD_CRONFILE |
---|
78 | echo "SHELL=/bin/sh" >> $UPD_CRONFILE |
---|
79 | echo "PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin" >> $UPD_CRONFILE |
---|
80 | |
---|
81 | for h in 2 4 6; do |
---|
82 | desync2cron $h 120 root /usr/sbin/athena-auto-update cron >> $UPD_CRONFILE |
---|
83 | done |
---|
84 | for h in 8 14 20; do |
---|
85 | desync2cron $h 360 root /usr/sbin/athena-auto-update cron >> $UPD_CRONFILE |
---|
86 | done |
---|
87 | echo "# Automatically generated by debathena-auto-update postinst" > $UPG_CRONFILE |
---|
88 | echo "SHELL=/bin/sh" >> $UPG_CRONFILE |
---|
89 | echo "PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin" >> $UPG_CRONFILE |
---|
90 | |
---|
91 | upginterval=360 |
---|
92 | hostname=`hostname | tr 'A-Z' 'a-z'` |
---|
93 | case $hostname in |
---|
94 | m38-370*) |
---|
95 | upginterval=480 |
---|
96 | ;; |
---|
97 | w20-575*) |
---|
98 | upginterval=420 |
---|
99 | ;; |
---|
100 | esac |
---|
101 | for h in 1 2 3; do |
---|
102 | desync2cron $h $upginterval root /usr/sbin/athena-auto-upgrade >> $UPG_CRONFILE |
---|
103 | done |
---|
104 | |
---|
105 | ;; |
---|
106 | |
---|
107 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
108 | ;; |
---|
109 | |
---|
110 | *) |
---|
111 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
112 | exit 1 |
---|
113 | ;; |
---|
114 | esac |
---|
115 | |
---|
116 | # dh_installdeb will replace this with shell code automatically |
---|
117 | # generated by other debhelper scripts. |
---|
118 | |
---|
119 | #DEBHELPER# |
---|
120 | |
---|
121 | exit 0 |
---|