Revision 25775,
674 bytes
checked in by jdreed, 12 years ago
(diff) |
In base:
* Make the /usr/athena symlinks more explicit because Python sucks
(Trac: #1126)
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
4 | |
---|
5 | # Hack to prevent dh_link from "canonicalizing" the /usr/athena and |
---|
6 | # /bin/athena symlinks to e.g. athena -> ../usr. This seems to not be |
---|
7 | # needed on recent distributions, but is still a problem on at least |
---|
8 | # dapper. |
---|
9 | DEB_DH_LINK_debathena-base = --your-mother || true |
---|
10 | |
---|
11 | common-install-indep:: |
---|
12 | mkdir -p $(DEB_DESTDIR)/usr/athena |
---|
13 | ln -nsf ../bin $(DEB_DESTDIR)/usr/athena/bin |
---|
14 | ln -nsf ../include $(DEB_DESTDIR)/usr/athena/include |
---|
15 | ln -nsf ../lib $(DEB_DESTDIR)/usr/athena/lib |
---|
16 | ln -nsf ../sbin $(DEB_DESTDIR)/usr/athena/sbin |
---|
17 | ln -nsf ../share $(DEB_DESTDIR)/usr/athena/share |
---|
18 | ln -s . $(DEB_DESTDIR)/bin/athena |
---|
Note: See
TracBrowser
for help on using the repository browser.