source: trunk/debathena/config/cluster-login-config/debian/rules @ 25283

Revision 25283, 2.5 KB checked in by jdreed, 13 years ago (diff)
In cluster-login-config: * Reduce pin priority of libstdc++5 to 200 * Don't enable lucid-backports or pinning on not-lucid
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3GDM_VERSION = $(shell dpkg-query --showformat='$${Version}' --show gdm)
4NEW_GDM = $(shell dpkg --compare-versions $(GDM_VERSION) ge '2.25.2~' && echo y)
5EVENT_D = $(shell test -f /etc/event.d/tty1 && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8ifneq ($(wildcard /etc/gdm/gdm.conf-custom.debathena),)
9    GDM_CONFFILE = /etc/gdm/gdm.conf-custom.debathena.debathena
10else
11    GDM_CONFFILE = /etc/gdm/gdm.conf.debathena.debathena
12endif
13DEB_UNDIVERT_FILES_debathena-cluster-login-config += \
14        /etc/default/kexec.debathena
15DEB_UNDIVERT_VERSION_/etc/default/kexec.debathena = 1.23~
16
17ifneq ($(NEW_GDM),y)
18    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
19        ${GDM_CONFFILE}
20else
21    DEB_REMOVE_FILES_debathena-cluster-login-config += \
22        /usr/share/xsessions/gnome-failsafe.desktop \
23        /usr/share/xsessions/xterm.desktop
24    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
25        /etc/pam.d/gdm.debathena.debathena
26    DEB_TRANSFORM_FILES_debathena-cluster-login-config += \
27        /etc/dbus-1/system.d/gdm.conf.debathena
28endif
29
30DEB_REMOVE_FILES_debathena-cluster-login-config += \
31    /usr/lib/indicator-session/indicator-users-service
32
33DEB_DIVERT_FILES_debathena-cluster-login-config += \
34        /sbin/getty.debathena
35
36ifeq ($(shell lsb_relase -sc),lucid)
37    install/debathena-cluster-login-config::
38        dh_install debian/debathena-backports.list etc/apt/sources.list.d
39        dh_install debian/debathena-libstdcplusplus.pref etc/apt/preferences.d
40endif
41
42ifeq ($(EVENT_D),y)
43    DEB_UNREMOVE_FILES_debathena-cluster-login-config += \
44        /etc/event.d/tty1 \
45        /etc/event.d/tty2 \
46        /etc/event.d/tty3 \
47        /etc/event.d/tty4 \
48        /etc/event.d/tty5 \
49        /etc/event.d/tty6
50    DEB_UNREMOVE_VERSION_/etc/event.d/tty1 = 1.24~
51    DEB_UNREMOVE_VERSION_/etc/event.d/tty2 = 1.24~
52    DEB_UNREMOVE_VERSION_/etc/event.d/tty3 = 1.24~
53    DEB_UNREMOVE_VERSION_/etc/event.d/tty4 = 1.24~
54    DEB_UNREMOVE_VERSION_/etc/event.d/tty5 = 1.24~
55    DEB_UNREMOVE_VERSION_/etc/event.d/tty6 = 1.24~
56else
57    DEB_UNREMOVE_FILES_debathena-cluster-login-config += \
58        /etc/init/tty1.conf \
59        /etc/init/tty2.conf \
60        /etc/init/tty3.conf \
61        /etc/init/tty4.conf \
62        /etc/init/tty5.conf \
63        /etc/init/tty6.conf
64    DEB_UNREMOVE_VERSION_/etc/init/tty1.conf = 1.24~
65    DEB_UNREMOVE_VERSION_/etc/init/tty2.conf = 1.24~
66    DEB_UNREMOVE_VERSION_/etc/init/tty3.conf = 1.24~
67    DEB_UNREMOVE_VERSION_/etc/init/tty4.conf = 1.24~
68    DEB_UNREMOVE_VERSION_/etc/init/tty5.conf = 1.24~
69    DEB_UNREMOVE_VERSION_/etc/init/tty6.conf = 1.24~
70endif
71
72include /usr/share/cdbs/1/rules/debhelper.mk
73include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.