1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_DIVERT_EXTENSION = .debathena |
---|
4 | |
---|
5 | # We used to divert kexec |
---|
6 | DEB_UNDIVERT_FILES_debathena-cluster-login-config += \ |
---|
7 | /etc/default/kexec.debathena \ |
---|
8 | # We diverted these for gdm << 2.25.2~, and there may be upgrades |
---|
9 | # from old-gdm to new-gdm. |
---|
10 | DEB_UNDIVERT_FILES_debathena-cluster-login-config += \ |
---|
11 | /etc/gdm/gdm.conf.debathena.debathena \ |
---|
12 | /etc/gdm/gdm.conf-custom.debathena.debathena |
---|
13 | |
---|
14 | # Remove some sessions we don't want. |
---|
15 | DEB_REMOVE_FILES_debathena-cluster-login-config += \ |
---|
16 | /usr/share/xsessions/gnome-failsafe.desktop \ |
---|
17 | /usr/share/xsessions/xterm.desktop |
---|
18 | # Transform the already-transformed gdm pam config |
---|
19 | # to prevent root login on console |
---|
20 | DEB_TRANSFORM_FILES_debathena-cluster-login-config += \ |
---|
21 | /etc/pam.d/gdm.debathena.debathena |
---|
22 | |
---|
23 | |
---|
24 | # Stop transforming gdm's dbus service |
---|
25 | # (was workaround for Lucid stupidity) |
---|
26 | DEB_UNDIVERT_FILES_debathena-cluster-login-config += \ |
---|
27 | /etc/dbus-1/system.d/gdm.conf.debathena |
---|
28 | |
---|
29 | # We used to remove this to disable user switching |
---|
30 | DEB_UNREMOVE_FILES_debathena-cluster-login-config += \ |
---|
31 | /usr/lib/indicator-session/indicator-users-service |
---|
32 | |
---|
33 | # Install our fake getty for the VTs |
---|
34 | DEB_DIVERT_FILES_debathena-cluster-login-config += \ |
---|
35 | /sbin/getty.debathena |
---|
36 | |
---|
37 | # We used to remove these. /etc/event.d is for Jaunty and earlier |
---|
38 | DEB_UNREMOVE_FILES_debathena-cluster-login-config += \ |
---|
39 | /etc/event.d/tty1 \ |
---|
40 | /etc/event.d/tty2 \ |
---|
41 | /etc/event.d/tty3 \ |
---|
42 | /etc/event.d/tty4 \ |
---|
43 | /etc/event.d/tty5 \ |
---|
44 | /etc/event.d/tty6 |
---|
45 | |
---|
46 | # Same as above, but for Karmic and later |
---|
47 | DEB_UNREMOVE_FILES_debathena-cluster-login-config += \ |
---|
48 | /etc/init/tty1.conf \ |
---|
49 | /etc/init/tty2.conf \ |
---|
50 | /etc/init/tty3.conf \ |
---|
51 | /etc/init/tty4.conf \ |
---|
52 | /etc/init/tty5.conf \ |
---|
53 | /etc/init/tty6.conf |
---|
54 | |
---|
55 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
56 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
57 | |
---|
58 | # dh_gconf needs to get called explicitly to install the |
---|
59 | # .gconf-mandatory and .gconf-defaults files |
---|
60 | install/debathena-cluster-login-config:: |
---|
61 | dh_gconf --priority 90 |
---|
62 | |
---|