Revision 23124,
1.0 KB
checked in by ghudson, 16 years ago
(diff) |
In dns-config:
* Add boot script to provide mit.edu as search path.
* Add postinst handler to restart bind9 and run boot script.
configure)
;;
abort-upgrade|abort-remove|abort-deconfigure)
;;
*)
echo "postinst called with unknown argument \`$1'" >&2
exit 1
;;
|
Rev | Line | |
---|
[23124] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for debathena-dns-config |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | #DEBHELPER# |
---|
| 22 | |
---|
| 23 | case "$1" in |
---|
| 24 | configure) |
---|
| 25 | if hash invoke-rc.d; then |
---|
| 26 | invoke-rc.d bind9 restart |
---|
| 27 | invoke-rc.d debathena-dns-config restart |
---|
| 28 | else |
---|
| 29 | /etc/init.d/bind9 restart |
---|
| 30 | /etc/init.d/debathena-dns-config restart |
---|
| 31 | fi |
---|
| 32 | ;; |
---|
| 33 | |
---|
| 34 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 35 | ;; |
---|
| 36 | |
---|
| 37 | *) |
---|
| 38 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 39 | exit 1 |
---|
| 40 | ;; |
---|
| 41 | esac |
---|
Note: See
TracBrowser
for help on using the repository browser.