Revision 25127,
1.1 KB
checked in by geofft, 13 years ago
(diff) |
In from-config:
* Use config-package-dev 4.12 (yay) to handle undiversions, instead of
a copy of a broken version of its undiversions code.
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[22685] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[25025] | 3 | BSDMAINUTILS_VERSION = $(shell dpkg-query --showformat='$${Version}' --show bsdmainutils) |
---|
| 4 | # From the changelog for bsdmainutils |
---|
| 5 | USES_ALTERNATIVES = $(shell dpkg --compare-versions $(BSDMAINUTILS_VERSION) ge '8.0.6~' && echo y) |
---|
| 6 | |
---|
[25027] | 7 | DEB_DIVERT_EXTENSION = .debathena |
---|
| 8 | ifneq ($(USES_ALTERNATIVES),y) |
---|
| 9 | # Older packages, continue to divert |
---|
[25025] | 10 | DEB_DIVERT_FILES_debathena-from-config += \ |
---|
[22685] | 11 | /usr/bin/from.debathena \ |
---|
| 12 | /usr/share/man/man1/from.debathena.1.gz |
---|
[25029] | 13 | binary-predeb/debathena-from-config:: |
---|
| 14 | echo "debathena-from-config-breaks=bsdmainutils (>= 8.0.6~)" >> debian/debathena-from-config.substvars |
---|
[25027] | 15 | else |
---|
| 16 | # Newer packages: undivert, generate Conflicts, generate postinst |
---|
[25127] | 17 | DEB_UNDIVERT_FILES_debathena-from-config += \ |
---|
| 18 | /usr/bin/from.debathena \ |
---|
| 19 | /usr/share/man/man1/from.debathena.1.gz |
---|
[25027] | 20 | binary-predeb/debathena-from-config:: |
---|
[25029] | 21 | echo "debathena-from-config-conflicts=bsdmainutils (<< 8.0.6~)" >> debian/debathena-from-config.substvars |
---|
[25027] | 22 | common-build-indep:: |
---|
[25028] | 23 | cp -f debian/postinst-alternatives debian/postinst |
---|
[25027] | 24 | clean:: |
---|
| 25 | rm -f debian/postinst |
---|
[25025] | 26 | endif |
---|
| 27 | |
---|
[22685] | 28 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
[22922] | 29 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[22849] | 30 | |
---|
Note: See
TracBrowser
for help on using the repository browser.