source: trunk/debathena/config/from-config/debian/rules @ 25029

Revision 25029, 1.1 KB checked in by jdreed, 14 years ago (diff)
Add a Breaks field and generate appropriate substvars line
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3BSDMAINUTILS_VERSION = $(shell dpkg-query --showformat='$${Version}' --show bsdmainutils)
4# From the changelog for bsdmainutils
5USES_ALTERNATIVES = $(shell dpkg --compare-versions $(BSDMAINUTILS_VERSION) ge '8.0.6~' && echo y)
6
7DEB_DIVERT_EXTENSION = .debathena
8ifneq ($(USES_ALTERNATIVES),y)
9    # Older packages, continue to divert
10    DEB_DIVERT_FILES_debathena-from-config += \
11        /usr/bin/from.debathena \
12        /usr/share/man/man1/from.debathena.1.gz
13    binary-predeb/debathena-from-config::
14        echo "debathena-from-config-breaks=bsdmainutils (>= 8.0.6~)" >> debian/debathena-from-config.substvars
15else
16    # Newer packages: undivert, generate Conflicts, generate postinst
17    # Except we can't use DEB_UNDIVERT_FILES because of Trac #549
18    binary-predeb/debathena-from-config::
19        echo "debathena-from-config-conflicts=bsdmainutils (<< 8.0.6~)" >> debian/debathena-from-config.substvars
20    common-build-indep::
21        cp -f debian/postinst-alternatives debian/postinst
22    clean::
23        rm -f debian/postinst
24endif
25
26include /usr/share/cdbs/1/rules/debhelper.mk
27include /usr/share/cdbs/1/rules/config-package.mk
28
Note: See TracBrowser for help on using the repository browser.