Revision 24025,
1.2 KB
checked in by geofft, 15 years ago
(diff) |
In gdm-config:
* Display the OS version and Debathena metapackage in the corner
of the login screen.
* To implement this feature, create debathena-*-branding packages for
metapackages that depend on gdm-config.
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for debathena-workstation-branding |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | case "$1" in |
---|
22 | configure) |
---|
23 | update-alternatives --install \ |
---|
24 | /usr/share/gdm/themes/debathena/metapackage.svg \ |
---|
25 | debathena-metapackage.svg \ |
---|
26 | /usr/share/gdm/themes/debathena/metapackage-workstation.svg \ |
---|
27 | 60 |
---|
28 | ;; |
---|
29 | |
---|
30 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
31 | ;; |
---|
32 | |
---|
33 | *) |
---|
34 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
35 | exit 1 |
---|
36 | ;; |
---|
37 | esac |
---|
38 | |
---|
39 | # dh_installdeb will replace this with shell code automatically |
---|
40 | # generated by other debhelper scripts. |
---|
41 | |
---|
42 | #DEBHELPER# |
---|
43 | |
---|
44 | exit 0 |
---|
45 | |
---|
46 | |
---|
Note: See
TracBrowser
for help on using the repository browser.