Revision 25598,
1.2 KB
checked in by jdreed, 12 years ago
(diff) |
In lightdm-config:
* Switch to config-package-dev instead of trying to place nice with what
the user has installed, because we need to clobber some additional
lightdm.conf settings; remove now-unused debconf templates
* Set user-authority-in-system-dir=true in lightdm.conf (Trac: #1161)
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for debathena-lightdm-config |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | # Source debconf library. |
---|
21 | . /usr/share/debconf/confmodule |
---|
22 | |
---|
23 | case "$1" in |
---|
24 | configure) |
---|
25 | db_get debathena-lightdm-config/force_lightdm |
---|
26 | if [ "$RET" = "true" ]; then |
---|
27 | db_set shared/default-x-display-manager "lightdm" |
---|
28 | echo "/usr/sbin/lightdm" > /etc/X11/default-display-manager |
---|
29 | fi |
---|
30 | ;; |
---|
31 | |
---|
32 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
33 | ;; |
---|
34 | |
---|
35 | *) |
---|
36 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
37 | exit 1 |
---|
38 | ;; |
---|
39 | esac |
---|
40 | |
---|
41 | # dh_installdeb will replace this with shell code automatically |
---|
42 | # generated by other debhelper scripts. |
---|
43 | |
---|
44 | #DEBHELPER# |
---|
45 | |
---|
46 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.