Revision 22685,
1.2 KB
checked in by ghudson, 17 years ago
(diff) |
* debathena/config: Snapshot config package sources from
/mit/debathena/packages/config.
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | # postinst script for debathena-nsswitch-config |
---|
3 | # |
---|
4 | # see: dh_installdeb(1) |
---|
5 | |
---|
6 | set -e |
---|
7 | |
---|
8 | # summary of how this script can be called: |
---|
9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
12 | # <new-version> |
---|
13 | # * <postinst> `abort-remove' |
---|
14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
15 | # <failed-install-package> <version> `removing' |
---|
16 | # <conflicting-package> <version> |
---|
17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
18 | # the debian-policy package |
---|
19 | |
---|
20 | |
---|
21 | #DEBHELPER# |
---|
22 | |
---|
23 | case "$1" in |
---|
24 | configure) |
---|
25 | if [ -x /var/lib/dpkg/info/libnss-mdns.postinst ]; then |
---|
26 | /var/lib/dpkg/info/libnss-mdns.postinst configure |
---|
27 | fi |
---|
28 | if ! [ -L /etc/nsswitch.conf ]; then |
---|
29 | echo "warning: /etc/nsswitch.conf is no longer a symbolic link! Fixing." >&2 |
---|
30 | if [ -s /etc/nsswitch.conf ]; then |
---|
31 | mv /etc/nsswitch.conf /etc/nsswitch.conf.debathena |
---|
32 | fi |
---|
33 | ln -sf nsswitch.conf.debathena /etc/nsswitch.conf |
---|
34 | fi |
---|
35 | ;; |
---|
36 | |
---|
37 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
38 | ;; |
---|
39 | |
---|
40 | *) |
---|
41 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
42 | exit 1 |
---|
43 | ;; |
---|
44 | esac |
---|
45 | |
---|
46 | exit 0 |
---|
47 | |
---|
48 | |
---|
Note: See
TracBrowser
for help on using the repository browser.