Revision 24528,
1.2 KB
checked in by jdreed, 14 years ago
(diff) |
Fix package name in maintainer scripts in multiple packages
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[24161] | 1 | #!/bin/sh |
---|
[24528] | 2 | # postinst script for debathena-printing-config |
---|
[24161] | 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | case "$1" in |
---|
| 22 | configure) |
---|
[24166] | 23 | if [ -e /etc/cups/lpoptions ]; then |
---|
| 24 | sed -i -e '/### BEGIN debathena-printing-config/,/### END debathena-printing-config/d' /etc/cups/lpoptions |
---|
[24161] | 25 | fi |
---|
[24201] | 26 | |
---|
[24206] | 27 | if dpkg --compare-versions "$2" lt 1.17~; then |
---|
[24201] | 28 | rm -f /etc/debathena-printing.conf || true |
---|
| 29 | fi |
---|
[24161] | 30 | ;; |
---|
| 31 | |
---|
| 32 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 33 | ;; |
---|
| 34 | |
---|
| 35 | *) |
---|
| 36 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 37 | exit 1 |
---|
| 38 | ;; |
---|
| 39 | esac |
---|
| 40 | |
---|
| 41 | # dh_installdeb will replace this with shell code automatically |
---|
| 42 | # generated by other debhelper scripts. |
---|
| 43 | |
---|
| 44 | #DEBHELPER# |
---|
| 45 | |
---|
| 46 | exit 0 |
---|
| 47 | |
---|
| 48 | |
---|
Note: See
TracBrowser
for help on using the repository browser.