[23055] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[24514] | 3 | DEB_PYTHON_SYSTEM = pysupport |
---|
| 4 | |
---|
[23055] | 5 | DEB_DIVERT_EXTENSION = .debathena |
---|
| 6 | |
---|
| 7 | DEB_DIVERT_FILES_debathena-printing-config += \ |
---|
| 8 | /usr/bin/lp.debathena \ |
---|
| 9 | /usr/bin/lpq.debathena \ |
---|
| 10 | /usr/bin/lpr.debathena \ |
---|
| 11 | /usr/bin/lprm.debathena \ |
---|
| 12 | \ |
---|
| 13 | /usr/share/man/man1/lp.debathena.1.gz \ |
---|
| 14 | /usr/share/man/man1/lpq.debathena.1.gz \ |
---|
| 15 | /usr/share/man/man1/lpr.debathena.1.gz \ |
---|
| 16 | /usr/share/man/man1/lprm.debathena.1.gz \ |
---|
| 17 | |
---|
[24202] | 18 | DEB_UNDIVERT_FILES_debathena-printing-config += \ |
---|
| 19 | /usr/bin/cancel.debathena \ |
---|
| 20 | /usr/sbin/lpc.debathena \ |
---|
| 21 | /usr/share/man/man1/cancel.debathena.1.gz \ |
---|
| 22 | /usr/share/man/man8/lpc.debathena.8.gz |
---|
| 23 | |
---|
[24205] | 24 | DEB_UNDIVERT_VERSION_/usr/bin/cancel.debathena = 1.17~ |
---|
| 25 | DEB_UNDIVERT_VERSION_/usr/sbin/lpc.debathena = 1.17~ |
---|
| 26 | DEB_UNDIVERT_VERSION_/usr/share/man/man1/cancel.debathena.1.gz = 1.17~ |
---|
| 27 | DEB_UNDIVERT_VERSION_/usr/share/man/man8/lpc.debathena.8.gz = 1.17~ |
---|
[24202] | 28 | |
---|
[23055] | 29 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 30 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[24514] | 31 | include /usr/share/cdbs/1/class/python-distutils.mk |
---|
[23952] | 32 | |
---|
[24517] | 33 | build/debathena-printing-config:: system-config-printer.mo |
---|
| 34 | system-config-printer.mo: system-config-printer.po |
---|
| 35 | msgfmt -o $@ $< |
---|
[24514] | 36 | |
---|
[24595] | 37 | ifeq (,$(findstring nocheck,$(DEB_BUILD_OPTIONS))) |
---|
| 38 | common-build-arch common-build-indep:: $(addprefix python-check-stamp-, $(cdbs_python_build_versions)) |
---|
| 39 | python-check-stamp-%: python-build-stamp-% |
---|
| 40 | $(call cdbs_python_binary,python$(cdbs_python_compile_version)) setup.py nosetests |
---|
| 41 | touch $@ |
---|
| 42 | |
---|
[24514] | 43 | clean:: |
---|
[24595] | 44 | rm -rf python-check-stamp-* mox-*.egg .coverage |
---|
| 45 | endif |
---|
| 46 | |
---|
| 47 | clean:: |
---|
[24517] | 48 | rm -rf debathena.printing.egg-info system-config-printer.mo |
---|