Revision 25536,
909 bytes
checked in by jdreed, 12 years ago
(diff) |
In reactivate:
* Set NSS_NONLOCAL_IGNORE when running getent, because we care about
local gruops, not Hesiod ones
* Add the user to "sudo" as well, since "admin" is gone in Precise (LP:
893842)
* Use SESSION_ID, not CHROOT_NAME in schroot setup script. SESSION_ID
was always right, and CHROOT_NAME simply happened to match it due to a
bug (Debian: 623828)
* Also divert lightdm-session (lightdm's session wrapper) and wrap it in
snapshot-run
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[23143] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
| 3 | DEB_DIVERT_EXTENSION = .debathena |
---|
| 4 | DEB_DIVERT_FILES_debathena-reactivate += \ |
---|
[25536] | 5 | /etc/gdm/Xsession.debathena \ |
---|
| 6 | /usr/sbin/lightdm-session.debathena |
---|
[23787] | 7 | DEB_TRANSFORM_FILES_debathena-reactivate += \ |
---|
[24404] | 8 | /etc/pam.d/su.debathena \ |
---|
[25223] | 9 | /etc/default/schroot.debathena \ |
---|
[25401] | 10 | /etc/pam.d/schroot.debathena \ |
---|
| 11 | /etc/dbus-1/system.conf.debathena |
---|
[23870] | 12 | DEB_REMOVE_FILES_debathena-reactivate += \ |
---|
[23869] | 13 | /etc/xdg/autostart/jockey-gtk.desktop \ |
---|
[24486] | 14 | /etc/xdg/autostart/update-notifier.desktop \ |
---|
| 15 | /etc/xdg/autostart/nm-applet.desktop |
---|
[24023] | 16 | |
---|
[24080] | 17 | DEB_UNDIVERT_FILES_debathena-reactivate += \ |
---|
| 18 | /etc/pam.d/sudo.debathena |
---|
[24205] | 19 | DEB_UNDIVERT_VERSION_/etc/pam.d/sudo.debathena = 1.25.2~ |
---|
[24080] | 20 | |
---|
[25223] | 21 | DEB_TRANSFORM_SCRIPT_/etc/default/schroot.debathena = \ |
---|
| 22 | debian/transform_schroot_defaults |
---|
| 23 | DEB_TRANSFORM_SCRIPT_/etc/pam.d/schroot.debathena = \ |
---|
| 24 | debian/transform_schroot_pam |
---|
| 25 | |
---|
[23143] | 26 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 27 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
Note: See
TracBrowser
for help on using the repository browser.