Revision 23353,
1.4 KB
checked in by tabbott, 16 years ago
(diff) |
In ssh-server-config:
* Remove DEB_AUTO_UPDATE_DEBIAN_CONTROL.
* Change "Debian-Athena Project" to "Debathena Project".
* Remove debian/control from version control.
* Clean up debian/copyright.
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[22685] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[22867] | 3 | DEB_DIVERT_EXTENSION = .debathena |
---|
| 4 | DEB_DIVERT_FILES_debathena-ssh-server-config += \ |
---|
[22685] | 5 | /etc/ssh/sshd_config.debathena |
---|
| 6 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
[22922] | 7 | include /usr/share/cdbs/1/rules/config-package.mk |
---|
[22685] | 8 | |
---|
| 9 | ifeq ($(shell dpkg --compare-versions \ |
---|
| 10 | "`dpkg-query --showformat='$${Version}' --show openssh-server`" ">=" 1:4.3 && echo y),y) |
---|
| 11 | |
---|
| 12 | PRIVSEP = yes |
---|
| 13 | debian/sshd_config.debathena-orig: /var/lib/dpkg/info/openssh-server.postinst |
---|
| 14 | perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@ |
---|
| 15 | |
---|
| 16 | else |
---|
| 17 | |
---|
| 18 | PRIVSEP = no |
---|
| 19 | debian/sshd_config.debathena-orig: /var/lib/dpkg/info/ssh-krb5.postinst |
---|
| 20 | perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*<<EOF[^\n]*\n.*\nEOF\n.*<<EOF[^\n]*\n(.*\n)EOF\n.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1$$2$$3/s or die;' $< > $@ |
---|
| 21 | |
---|
| 22 | endif |
---|
| 23 | |
---|
| 24 | common-build-indep:: debian/sshd_config.debathena |
---|
| 25 | |
---|
| 26 | debian/sshd_config.debathena: debian/sshd_config.debathena-orig |
---|
| 27 | perl -0pe ' \ |
---|
| 28 | s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes/m and \ |
---|
| 29 | s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \ |
---|
| 30 | s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \ |
---|
| 31 | s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation $(PRIVSEP)/m and \ |
---|
| 32 | s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@ |
---|
| 33 | |
---|
| 34 | clean:: |
---|
| 35 | rm -f debian/sshd_config.debathena debian/sshd_config.debathena-orig |
---|
Note: See
TracBrowser
for help on using the repository browser.