source: trunk/debathena/config/ssh-server-config/debian/rules @ 22922

Revision 22922, 1.4 KB checked in by tabbott, 16 years ago (diff)
Convert config packages to use new config-package-dev 4.5.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_DEBIAN_CONTROL = 1
4DEB_DIVERT_EXTENSION = .debathena
5DEB_DIVERT_FILES_debathena-ssh-server-config += \
6        /etc/ssh/sshd_config.debathena
7include /usr/share/cdbs/1/rules/debhelper.mk
8include /usr/share/cdbs/1/rules/config-package.mk
9
10ifeq ($(shell dpkg --compare-versions \
11        "`dpkg-query --showformat='$${Version}' --show openssh-server`" ">=" 1:4.3 && echo y),y)
12
13PRIVSEP = yes
14debian/sshd_config.debathena-orig: /var/lib/dpkg/info/openssh-server.postinst
15        perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@
16
17else
18
19PRIVSEP = no
20debian/sshd_config.debathena-orig: /var/lib/dpkg/info/ssh-krb5.postinst
21        perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*<<EOF[^\n]*\n.*\nEOF\n.*<<EOF[^\n]*\n(.*\n)EOF\n.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1$$2$$3/s or die;' $< > $@
22
23endif
24
25common-build-indep:: debian/sshd_config.debathena
26
27debian/sshd_config.debathena: debian/sshd_config.debathena-orig
28        perl -0pe ' \
29            s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes/m and \
30            s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \
31            s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \
32            s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation $(PRIVSEP)/m and \
33            s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@
34
35clean::
36        rm -f debian/sshd_config.debathena debian/sshd_config.debathena-orig
Note: See TracBrowser for help on using the repository browser.