source: trunk/debathena/config/ssl-certificates/debian/debathena-ssl-certificates.postinst @ 23461

Revision 23461, 1.3 KB checked in by andersk, 15 years ago (diff)
In ssl-certificates: * Let the MIT CA be managed by update-ca-certificates. (This causes the CA to be added to /etc/ssl/certs/ca-certificates.crt, and also lets Java use the CA.)
Line 
1#!/bin/sh
2# postinst script for debathena-ssl-certificates
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        perl -0pe '
24s/^### BEGIN debathena-ssl-certificates\n.*?^### END debathena-ssl-certificates\n//msg;
25s/\n?$/\n### BEGIN debathena-ssl-certificates
26# This section is automatically added by the debathena-ssl-certificates
27# package.
28mit.edu\/mitCAclient.crt
29mit.edu\/mitCA.crt
30### END debathena-ssl-certificates
31/;
32' -i /etc/ca-certificates.conf
33        update-ca-certificates
34    ;;
35
36    abort-upgrade|abort-remove|abort-deconfigure)
37    ;;
38
39    *)
40        echo "postinst called with unknown argument \`$1'" >&2
41        exit 1
42    ;;
43esac
44
45# dh_installdeb will replace this with shell code automatically
46# generated by other debhelper scripts.
47
48#DEBHELPER#
49
50exit 0
Note: See TracBrowser for help on using the repository browser.