source: trunk/debathena/debathena/debathena-pyhesiodfs/debian/debathena-pyhesiodfs.postinst @ 23080

Revision 23080, 1.1 KB checked in by broder, 16 years ago (diff)
Add debathena-pyhesiodfs package to replace insecure debathena-afuse-automounter
Line 
1#!/bin/sh
2# postinst script for debathena-python-pyhesiodfs
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21# dh_installdeb will replace this with shell code automatically
22# generated by other debhelper scripts.
23
24#DEBHELPER#
25
26case "$1" in
27    configure)
28        if hash invoke-rc.d 2>/dev/null; then
29            invoke-rc.d debathena-pyhesiodfs restart
30        else
31            /etc/init.d/debathena-pyhesiodfs restart
32        fi
33    ;;
34
35    abort-upgrade|abort-remove|abort-deconfigure)
36    ;;
37
38    *)
39        echo "postinst called with unknown argument \`$1'" >&2
40        exit 1
41    ;;
42esac
43
44exit 0
45
46
Note: See TracBrowser for help on using the repository browser.