source: trunk/debathena/debathena/dotfiles/debian/rules @ 22798

Revision 22798, 697 bytes checked in by ghudson, 17 years ago (diff)
* debathena/debathena/dotfiles: Copy packs/dotfiles back from the attic and import the Debathena packaging materials. The goal is to simplify this source tree by eliminating multi-OS concerns, but starting from the existing tree seems easiest.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_AUTO_UPDATE_DEBIAN_CONTROL = 1
4include /usr/share/cdbs/1/rules/debhelper.mk
5include /usr/share/cdbs/1/class/makefile.mk
6include /usr/share/cdbs/1/rules/patchsys-quilt.mk
7
8OS = linux
9ATHENA_MAJOR_VERSION = 9
10ATHENA_MINOR_VERSION = 4
11
12DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR)
13DEB_MAKE_INVOKE += OS=$(OS) ATHENA_MAJOR_VERSION=$(ATHENA_MAJOR_VERSION) ATHENA_MINOR_VERSION=$(ATHENA_MINOR_VERSION)
14DEB_DESTDIR = $(CURDIR)/debian/tmp/
15DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR)
16DEB_DH_INSTALLINIT_ARGS = --no-start
17DEB_UPDATE_RCD_PARAMS = "start 65 S ."
18
19common-install::
20        chmod a=rwx,o+t $(DEB_DESTDIR)/var/run/athena-sessions
21
22clean::
23        rm -f gnome/athena.schemas
Note: See TracBrowser for help on using the repository browser.