Revision 22798,
697 bytes
checked in by ghudson, 17 years ago
(diff) |
* debathena/debathena/dotfiles: Copy packs/dotfiles back from the attic
and import the Debathena packaging materials. The goal is to
simplify this source tree by eliminating multi-OS concerns, but
starting from the existing tree seems easiest.
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_AUTO_UPDATE_DEBIAN_CONTROL = 1 |
---|
4 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
5 | include /usr/share/cdbs/1/class/makefile.mk |
---|
6 | include /usr/share/cdbs/1/rules/patchsys-quilt.mk |
---|
7 | |
---|
8 | OS = linux |
---|
9 | ATHENA_MAJOR_VERSION = 9 |
---|
10 | ATHENA_MINOR_VERSION = 4 |
---|
11 | |
---|
12 | DEB_MAKE_INSTALL_TARGET = install DESTDIR=$(DEB_DESTDIR) |
---|
13 | DEB_MAKE_INVOKE += OS=$(OS) ATHENA_MAJOR_VERSION=$(ATHENA_MAJOR_VERSION) ATHENA_MINOR_VERSION=$(ATHENA_MINOR_VERSION) |
---|
14 | DEB_DESTDIR = $(CURDIR)/debian/tmp/ |
---|
15 | DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR) |
---|
16 | DEB_DH_INSTALLINIT_ARGS = --no-start |
---|
17 | DEB_UPDATE_RCD_PARAMS = "start 65 S ." |
---|
18 | |
---|
19 | common-install:: |
---|
20 | chmod a=rwx,o+t $(DEB_DESTDIR)/var/run/athena-sessions |
---|
21 | |
---|
22 | clean:: |
---|
23 | rm -f gnome/athena.schemas |
---|
Note: See
TracBrowser
for help on using the repository browser.