source: trunk/debathena/debathena/libnss-nonlocal/debian/rules @ 26035

Revision 26035, 2.7 KB checked in by andersk, 11 years ago (diff)
In libnss-nonlocal: * New upstream release. - Support Automake 1.12. - Guard one-time initialization with memory barriers. - Make initgroups_dyn succeed when adding only magic groups. * Rewrite packaging with Debhelper 7. * Move magic user and group creation to separate libnss-nonlocal-common package. Full history: git://andersk.mit.edu/nss_nonlocal.git debian/2.1-0debathena1
  • Property svn:executable set to *
RevLine 
[22686]1#!/usr/bin/make -f
2
[26035]3DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
[23113]4
[26035]5# Work around http://bugs.debian.org/572077 (debhelper < 7.4.16)
6binary: binary-arch binary-indep ;
[25083]7
[26035]8%:
9        dh $@ --with autoreconf
[22686]10
[26035]11all_flavors = libnss-nonlocal
12libnss-nonlocal_configure_args += --prefix=/
13libnss-nonlocal_dh_install = 'lib/*'
[23113]14
[25083]15ifneq ($(DEB_HOST_MULTIARCH),)
16    export DH_COMPAT = 9
[26035]17    libnss-nonlocal_configure_args += --libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)'
18    libnss-nonlocal_dh_install = 'lib/$(DEB_HOST_MULTIARCH)/*'
19    libnss-nonlocal_dh_gencontrol = -- -DMulti-Arch=same
20else ifeq ($(shell hash dpkg-buildflags 2>/dev/null && echo y),y)
21    all_configure_args += $(foreach var,CFLAGS CPPFLAGS LDFLAGS,"$(var)=$$(dpkg-buildflags --get $(var))")
[25083]22endif
23
[24755]24IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y)
[23450]25LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6)
[24585]26libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y)
27
[26035]28all_flavors += lib32nss-nonlocal
[24585]29# i386_configure_target in eglibc/debian/sysdeps/amd64.mk
[24755]30ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y)
[26035]31lib32nss-nonlocal_configure_args += --build=i686-linux
[24585]32else
[26035]33lib32nss-nonlocal_configure_args += --build=i486-linux
[24585]34endif
35# i386_CC in eglibc/debian/sysdeps/amd64.mk
[26035]36lib32nss-nonlocal_configure_args += CC='$(CC) -m32'
[24585]37# i386_slibdir in eglibc/debian/sysdeps/amd64.mk
[24755]38ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.9-14~)),y)
[26035]39lib32nss-nonlocal_configure_args += --prefix=/ --libdir='$${prefix}/lib32'
40lib32nss-nonlocal_dh_install = 'lib32/*'
[23880]41else
[26035]42lib32nss-nonlocal_configure_args += --prefix=/emul/ia32-linux
43lib32nss-nonlocal_dh_install = 'emul/ia32-linux/*'
[23880]44endif
45
[26035]46all_flavors += lib64nss-nonlocal
[24585]47# amd64_configure_target in eglibc/debian/sysdeps/i386.mk
[26035]48lib64nss-nonlocal_configure_args += --build=x86_64-linux
[24585]49# amd64_CC in eglibc/debian/sysdeps/i386.mk
[26035]50lib64nss-nonlocal_configure_args += CC='$(CC) -m64 -D__x86_64__'
[24585]51# amd64_slibdir in eglibc/debian/sysdeps/i386.mk
[26035]52lib64nss-nonlocal_configure_args += --prefix=/ --libdir="\$${prefix}/lib64"
[23880]53
[26035]54flavors := $(filter $(all_flavors),$(shell dh_listpackages))
[24756]55
[26035]56define do_overrides
57override_$(1): $(addsuffix _$(1),$(2))
58$(addsuffix _$(1),$(filter-out REMAINING,$(2))): %_$(1):
59        $(1) -p$$* $(3)
60REMAINING_$(1): $(addsuffix _$(1),$(filter-out REMAINING,$(2)))
61        $(1) --remaining-packages $(4)
[23880]62
[26035]63endef
[23880]64
[26035]65$(eval $(foreach auto,configure build install test clean,$(call do_overrides,dh_auto_$(auto),$(flavors),-Bdebian/build_$$* -- $$(all_$(auto)_args) $$($$*_$(auto)_args))))
66$(eval $(call do_overrides,dh_install,$(flavors) REMAINING,$$($$*_dh_install)))
67$(eval $(call do_overrides,dh_gencontrol,libnss-nonlocal REMAINING,$$($$*_dh_gencontrol)))
Note: See TracBrowser for help on using the repository browser.