1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_AUTO_UPDATE_AUTOCONF = 2.50 |
---|
4 | DEB_AUTO_UPDATE_AUTOHEADER = 2.50 |
---|
5 | DEB_AUTO_UPDATE_AUTOMAKE = 1.9 |
---|
6 | DEB_AUTO_UPDATE_ACLOCAL = 1.9 |
---|
7 | DEB_AUTO_UPDATE_LIBTOOL = pre |
---|
8 | |
---|
9 | # Fix http://bugs.debian.org/576967 : CDBS 0.4.77 in squeeze |
---|
10 | # incorrectly splits multiword $(CC) and $(CXX). |
---|
11 | override cdbs_set_nondefaultvars = $(foreach var,$1,$(if $(filter-out $(origin $(var)),default),$(var)='$($(var))')) |
---|
12 | |
---|
13 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
14 | include /usr/share/cdbs/1/class/autotools.mk |
---|
15 | |
---|
16 | DEB_DESTDIR = $(CURDIR)/debian/tmp/ |
---|
17 | DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR) |
---|
18 | DEB_CONFIGURE_PREFIX = / |
---|
19 | |
---|
20 | IS_UBUNTU := $(if $(filter Ubuntu, $(shell lsb_release -is)), y) |
---|
21 | LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6) |
---|
22 | libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y) |
---|
23 | |
---|
24 | ifeq ($(call libc6_ge, 2.8+20080809), y) |
---|
25 | DEB_DH_SHLIBDEPS_ARGS = -- -xglibc-private |
---|
26 | endif |
---|
27 | |
---|
28 | debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing |
---|
29 | |
---|
30 | debian/stamp-autotools-files: aclocal.m4 |
---|
31 | aclocal.m4: |
---|
32 | touch $@ |
---|
33 | |
---|
34 | DEB_BUILDDIR = $(or $(DEB_BUILDDIR_$(cdbs_curpkg)),debian/build) |
---|
35 | |
---|
36 | REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE) |
---|
37 | |
---|
38 | DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32 |
---|
39 | cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal |
---|
40 | configure/lib32nss-nonlocal:: cdbs_crossbuild = |
---|
41 | # i386_configure_target in eglibc/debian/sysdeps/amd64.mk |
---|
42 | ifeq ($(or $(IS_UBUNTU), $(call libc6_ge, 2.8+20080809)), y) |
---|
43 | configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux |
---|
44 | else |
---|
45 | configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux |
---|
46 | endif |
---|
47 | # i386_CC in eglibc/debian/sysdeps/amd64.mk |
---|
48 | configure/lib32nss-nonlocal:: CC += -m32 |
---|
49 | # i386_slibdir in eglibc/debian/sysdeps/amd64.mk |
---|
50 | ifeq ($(or $(IS_UBUNTU), $(call libc6_ge, 2.9-14~)), y) |
---|
51 | configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32" |
---|
52 | binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'lib32/*' |
---|
53 | else |
---|
54 | configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux |
---|
55 | binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'emul/ia32-linux/lib/*' |
---|
56 | endif |
---|
57 | |
---|
58 | DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64 |
---|
59 | cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal |
---|
60 | configure/lib64nss-nonlocal:: cdbs_crossbuild = |
---|
61 | # amd64_configure_target in eglibc/debian/sysdeps/i386.mk |
---|
62 | configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux |
---|
63 | # amd64_CC in eglibc/debian/sysdeps/i386.mk |
---|
64 | configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__ |
---|
65 | # amd64_slibdir in eglibc/debian/sysdeps/i386.mk |
---|
66 | configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64" |
---|
67 | |
---|
68 | configure/lib32nss-nonlocal configure/lib64nss-nonlocal:: |
---|
69 | $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS) |
---|
70 | |
---|
71 | build/lib32nss-nonlocal build/lib64nss-nonlocal:: |
---|
72 | +$(DEB_MAKE_INVOKE) $(DEB_MAKE_BUILD_TARGET) |
---|
73 | |
---|
74 | install/lib32nss-nonlocal install/lib64nss-nonlocal:: |
---|
75 | +$(DEB_MAKE_INVOKE) $(DEB_MAKE_INSTALL_TARGET) |
---|
76 | |
---|
77 | clean/lib32nss-nonlocal clean/lib64nss-nonlocal:: |
---|
78 | +-$(DEB_MAKE_INVOKE) -k $(DEB_MAKE_CLEAN_TARGET) |
---|
79 | |
---|
80 | clean:: |
---|
81 | rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \ |
---|
82 | configure config.h.in missing depcomp Makefile.in |
---|