1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | DEB_AUTO_UPDATE_AUTOCONF = 2.61 |
---|
4 | DEB_AUTO_UPDATE_AUTOHEADER = 2.61 |
---|
5 | DEB_AUTO_UPDATE_AUTOMAKE = 1.10 |
---|
6 | DEB_AUTO_UPDATE_ACLOCAL = 1.10 |
---|
7 | DEB_AUTO_UPDATE_LIBTOOL = pre |
---|
8 | |
---|
9 | # dh_buildinfo fails at multiarch: http://bugs.debian.org/620104 |
---|
10 | CDBS_BUILD_DEPENDS_rules_debhelper_buildinfo = |
---|
11 | |
---|
12 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
13 | include /usr/share/cdbs/1/class/autotools.mk |
---|
14 | |
---|
15 | DEB_DESTDIR = $(CURDIR)/debian/tmp/ |
---|
16 | DEB_DH_INSTALL_SOURCEDIR = $(DEB_DESTDIR) |
---|
17 | DEB_CONFIGURE_PREFIX = / |
---|
18 | |
---|
19 | ifneq ($(DEB_HOST_MULTIARCH),) |
---|
20 | CDBS_BUILD_DEPENDS := $(CDBS_BUILD_DEPENDS) |
---|
21 | export DH_COMPAT = 9 |
---|
22 | DEB_CONFIGURE_EXTRA_FLAGS += $(MULTIARCH_CONFIGURE_FLAGS) |
---|
23 | MULTIARCH_CONFIGURE_FLAGS = --libdir='$${prefix}/lib/$(DEB_HOST_MULTIARCH)' |
---|
24 | DEB_DH_GENCONTROL_ARGS_libnss-nonlocal += -- -DMulti-Arch=same |
---|
25 | endif |
---|
26 | |
---|
27 | IS_UBUNTU := $(if $(filter Ubuntu,$(shell lsb_release -is)),y) |
---|
28 | LIBC6_VERSION := $(shell dpkg-query --showformat='$${Version}' --show libc6) |
---|
29 | libc6_ge = $(shell dpkg --compare-versions '$(LIBC6_VERSION)' ge '$(1)' && echo y) |
---|
30 | |
---|
31 | debian/stamp-autotools-files: DEB_AUTO_UPDATE_AUTOMAKE += --foreign --add-missing |
---|
32 | |
---|
33 | debian/stamp-autotools-files: aclocal.m4 |
---|
34 | aclocal.m4: |
---|
35 | touch $@ |
---|
36 | |
---|
37 | DEB_BUILDDIR = $(or $(DEB_BUILDDIR_$(cdbs_curpkg)),debian/build) |
---|
38 | |
---|
39 | REAL_DEB_HOST_GNU_TYPE := $(DEB_HOST_GNU_TYPE) |
---|
40 | |
---|
41 | DEB_BUILDDIR_lib32nss-nonlocal = debian/build_32 |
---|
42 | cleanbuilddir/lib32nss-nonlocal:: clean/lib32nss-nonlocal |
---|
43 | configure/lib32nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS = |
---|
44 | configure/lib32nss-nonlocal:: cdbs_crossbuild = |
---|
45 | # i386_configure_target in eglibc/debian/sysdeps/amd64.mk |
---|
46 | ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.8+20080809)),y) |
---|
47 | configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i686-linux |
---|
48 | else |
---|
49 | configure/lib32nss-nonlocal:: DEB_BUILD_GNU_TYPE = i486-linux |
---|
50 | endif |
---|
51 | # i386_CC in eglibc/debian/sysdeps/amd64.mk |
---|
52 | configure/lib32nss-nonlocal:: CC += -m32 |
---|
53 | # i386_slibdir in eglibc/debian/sysdeps/amd64.mk |
---|
54 | ifeq ($(or $(IS_UBUNTU),$(call libc6_ge,2.9-14~)),y) |
---|
55 | configure/lib32nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib32" |
---|
56 | binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'lib32/*' |
---|
57 | else |
---|
58 | configure/lib32nss-nonlocal:: DEB_CONFIGURE_PREFIX = /emul/ia32-linux |
---|
59 | binary-install/lib32nss-nonlocal:: DEB_DH_INSTALL_ARGS = 'emul/ia32-linux/lib/*' |
---|
60 | endif |
---|
61 | |
---|
62 | DEB_BUILDDIR_lib64nss-nonlocal = debian/build_64 |
---|
63 | cleanbuilddir/lib64nss-nonlocal:: clean/lib64nss-nonlocal |
---|
64 | configure/lib64nss-nonlocal:: MULTIARCH_CONFIGURE_FLAGS = |
---|
65 | configure/lib64nss-nonlocal:: cdbs_crossbuild = |
---|
66 | # amd64_configure_target in eglibc/debian/sysdeps/i386.mk |
---|
67 | configure/lib64nss-nonlocal:: DEB_BUILD_GNU_TYPE = x86_64-linux |
---|
68 | # amd64_CC in eglibc/debian/sysdeps/i386.mk |
---|
69 | configure/lib64nss-nonlocal:: CC += -m64 -D__x86_64__ |
---|
70 | # amd64_slibdir in eglibc/debian/sysdeps/i386.mk |
---|
71 | configure/lib64nss-nonlocal:: DEB_CONFIGURE_EXTRA_FLAGS += --libdir="\$${prefix}/lib64" |
---|
72 | |
---|
73 | # Fix for CDBS ≥ 0.4.59ubuntu4, < 0.4.83ubuntu1 (karmic and lucid). |
---|
74 | configure/lib32nss-nonlocal configure/lib64nss-nonlocal:: DEB_CONFIGURE_SCRIPT_ENV += CC="$(CC)" |
---|
75 | |
---|
76 | configure/lib32nss-nonlocal configure/lib64nss-nonlocal:: |
---|
77 | $(DEB_CONFIGURE_INVOKE) $(cdbs_configure_flags) $(DEB_CONFIGURE_EXTRA_FLAGS) $(DEB_CONFIGURE_USER_FLAGS) |
---|
78 | |
---|
79 | build/lib32nss-nonlocal build/lib64nss-nonlocal:: |
---|
80 | +$(DEB_MAKE_INVOKE) $(DEB_MAKE_BUILD_TARGET) |
---|
81 | |
---|
82 | install/lib32nss-nonlocal install/lib64nss-nonlocal:: |
---|
83 | +$(DEB_MAKE_INVOKE) $(DEB_MAKE_INSTALL_TARGET) |
---|
84 | |
---|
85 | clean/lib32nss-nonlocal clean/lib64nss-nonlocal:: |
---|
86 | +-$(DEB_MAKE_INVOKE) -k $(DEB_MAKE_CLEAN_TARGET) |
---|
87 | |
---|
88 | clean:: |
---|
89 | rm -f aclocal.m4 config.guess config.sub install-sh ltmain.sh \ |
---|
90 | configure config.h.in missing depcomp Makefile.in |
---|