Revision 23238,
1.5 KB
checked in by andersk, 16 years ago
(diff) |
In pyhesiodfs:
* If /dev/fuse has group root, restart udev to work around LP #293502.
|
Rev | Line | |
---|
[23080] | 1 | #!/bin/sh |
---|
| 2 | # postinst script for debathena-python-pyhesiodfs |
---|
| 3 | # |
---|
| 4 | # see: dh_installdeb(1) |
---|
| 5 | |
---|
| 6 | set -e |
---|
| 7 | |
---|
| 8 | # summary of how this script can be called: |
---|
| 9 | # * <postinst> `configure' <most-recently-configured-version> |
---|
| 10 | # * <old-postinst> `abort-upgrade' <new version> |
---|
| 11 | # * <conflictor's-postinst> `abort-remove' `in-favour' <package> |
---|
| 12 | # <new-version> |
---|
| 13 | # * <postinst> `abort-remove' |
---|
| 14 | # * <deconfigured's-postinst> `abort-deconfigure' `in-favour' |
---|
| 15 | # <failed-install-package> <version> `removing' |
---|
| 16 | # <conflicting-package> <version> |
---|
| 17 | # for details, see http://www.debian.org/doc/debian-policy/ or |
---|
| 18 | # the debian-policy package |
---|
| 19 | |
---|
| 20 | |
---|
| 21 | # dh_installdeb will replace this with shell code automatically |
---|
| 22 | # generated by other debhelper scripts. |
---|
| 23 | |
---|
| 24 | #DEBHELPER# |
---|
| 25 | |
---|
| 26 | case "$1" in |
---|
| 27 | configure) |
---|
[23151] | 28 | adduser pyhesiodfs fuse |
---|
| 29 | |
---|
[23080] | 30 | if hash invoke-rc.d 2>/dev/null; then |
---|
[23238] | 31 | # If /dev/fuse has group root, restart udev to work around |
---|
| 32 | # <https://bugs.launchpad.net/ubuntu/+source/fuse/+bug/293502> |
---|
| 33 | [ "$(stat -c %g /dev/fuse)" != 0 ] || invoke-rc.d udev restart || : |
---|
[23080] | 34 | invoke-rc.d debathena-pyhesiodfs restart |
---|
| 35 | else |
---|
[23238] | 36 | [ "$(stat -c %g /dev/fuse)" != 0 ] || /etc/init.d/udev restart || : |
---|
[23080] | 37 | /etc/init.d/debathena-pyhesiodfs restart |
---|
| 38 | fi |
---|
[23151] | 39 | update-rc.d -f debathena-afuse-automounter remove >/dev/null || : |
---|
[23080] | 40 | ;; |
---|
| 41 | |
---|
| 42 | abort-upgrade|abort-remove|abort-deconfigure) |
---|
| 43 | ;; |
---|
| 44 | |
---|
| 45 | *) |
---|
| 46 | echo "postinst called with unknown argument \`$1'" >&2 |
---|
| 47 | exit 1 |
---|
| 48 | ;; |
---|
| 49 | esac |
---|
| 50 | |
---|
| 51 | exit 0 |
---|
| 52 | |
---|
| 53 | |
---|
Note: See
TracBrowser
for help on using the repository browser.