source: trunk/debathena/debathena/pyhesiodfs/debian/rules @ 23572

Revision 23572, 697 bytes checked in by broder, 16 years ago (diff)
In clusterinfo: * Update clusterinfo late enough in the boot process that there's a chance networking will be up. In pyhesiodfs: * Start pyhesiodfs before ssh so that users don't end up without their homedirs
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4DEB_DIVERT_FILES_debathena-pyhesiodfs += \
5        /etc/fuse.conf.debathena
6DEB_PYTHON_SYSTEM=pysupport
7
8ifneq ($(shell grep RESTART_AFTER_UPGRADE /usr/bin/dh_installinit),)
9        DEB_DH_INSTALLINIT_ARGS += --restart-after-upgrade
10endif
11
12DEB_UPDATE_RCD_PARAMS_debathena-pyhesiodfs += defaults 15 85
13
14clean::
15        if [ -f pyhesiodfs ]; then mv pyhesiodfs pyHesiodFS.py; fi
16
17include /usr/share/cdbs/1/rules/debhelper.mk
18include /usr/share/cdbs/1/rules/patchsys-quilt.mk
19include /usr/share/cdbs/1/rules/config-package.mk
20include /usr/share/cdbs/1/class/python-distutils.mk
21
22common-configure-indep::
23        if [ -f pyHesiodFS.py ]; then mv pyHesiodFS.py pyhesiodfs; fi
Note: See TracBrowser for help on using the repository browser.