source: trunk/debathena/debathena/thirdparty-installer/debian/debathena-thirdparty-installer.postinst @ 25654

Revision 25654, 1.1 KB checked in by jdreed, 12 years ago (diff)
In thirdparty-installer: * Initial release.
Line 
1#!/bin/sh
2# postinst script for debathena-thirdparty-installer
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        touch /var/lib/debathena-thirdparty/update_required
24        echo "ok|Package configured" > /var/lib/debathena-thirdparty/status
25    ;;
26
27    abort-upgrade|abort-remove|abort-deconfigure)
28    ;;
29
30    *)
31        echo "postinst called with unknown argument \`$1'" >&2
32        exit 1
33    ;;
34esac
35
36# dh_installdeb will replace this with shell code automatically
37# generated by other debhelper scripts.
38
39#DEBHELPER#
40
41exit 0
Note: See TracBrowser for help on using the repository browser.