source: trunk/debathena/meta/extra-software/debian/rules @ 25855

Revision 25855, 433 bytes checked in by jdreed, 11 years ago (diff)
In extra-software: * Recommend motif-clients (Trac: #946) * Convert from CDBS to dh7 * Remove X-Debathena-Nobuild line now that hardy isn't a thing * Explicitly depend on icedtea6-plugin, as there are no releases without it anymore. * Bump Standards-Version to 3.9.3 * Change copyright file to new copyright format
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3%:
4        dh $@
5
6HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y)
7
8override_dh_gencontrol:
9ifeq ($(HAVE_LIBREOFFICE),y)
10        dh_gencontrol -- -Vdebathena-cool-kids-office-suite=libreoffice
11else
12        dh_gencontrol -- -Vdebathena-cool-kids-office-suite=openoffice.org
13endif
14
15ifeq ($(HAVE_LIBREOFFICE),y)
16override_dh_install:
17        dh_install
18        dh_install debian/ooffice usr/bin
19endif
20
Note: See TracBrowser for help on using the repository browser.