Revision 25341,
836 bytes
checked in by jdreed, 12 years ago
(diff) |
In extra-software:
* Drop dependency on openoffice.org-java-common, since openoffice.org
(which we also depend on) depends on openoffice.org-java-common
* Conditionally depend on libreoffice and ship a wrapper (for now)
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | HAVE_ICEDTEA = $(shell apt-cache show icedtea6-plugin 2>/dev/null | grep -q '^Version:' && echo y) |
---|
4 | HAVE_LIBREOFFICE = $(shell apt-cache show libreoffice 2>/dev/null | grep -q '^Version:' && echo y) |
---|
5 | |
---|
6 | ifeq ($(HAVE_ICEDTEA),y) |
---|
7 | binary-predeb/debathena-extra-software:: |
---|
8 | echo "debathena-java-plugin=icedtea6-plugin" >> debian/debathena-extra-software.substvars |
---|
9 | endif |
---|
10 | |
---|
11 | ifeq ($(HAVE_LIBREOFFICE),y) |
---|
12 | install/debathena-extra-software:: |
---|
13 | dh_install debian/ooffice usr/bin |
---|
14 | binary-predeb/debathena-extra-software:: |
---|
15 | echo "debathena-cool-kids-office-suite=libreoffice" >> debian/debathena-extra-software.substvars |
---|
16 | else |
---|
17 | binary-predeb/debathena-extra-software:: |
---|
18 | echo "debathena-cool-kids-office-suite=openoffice.org" >> debian/debathena-extra-software.substvars |
---|
19 | endif |
---|
20 | |
---|
21 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
Note: See
TracBrowser
for help on using the repository browser.