Revision 24030,
631 bytes
checked in by broder, 15 years ago
(diff) |
Create debathena-language-support to depend on all input methods
available.
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[24030] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
| 3 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 4 | |
---|
| 5 | APTITUDE_LOCKFILE = $(CURDIR)/debian/aptitude-lockfile |
---|
| 6 | APTITUDE = aptitude -o 'Aptitude::LockFile=$(APTITUDE_LOCKFILE)' -o 'Debug::NoLocking=yes' |
---|
| 7 | |
---|
| 8 | common-build-indep:: debian/deps |
---|
| 9 | |
---|
| 10 | debian/deps: |
---|
| 11 | echo -n "debathena-language-support:Depends=" > $@ |
---|
| 12 | $(APTITUDE) search '~n^language-support-input-' -F '%p' | \ |
---|
| 13 | tr '\n' ',' >> $@; |
---|
| 14 | echo >> $@ |
---|
| 15 | |
---|
| 16 | binary-predeb/debathena-language-support:: add-deps/debathena-language-support |
---|
| 17 | |
---|
| 18 | add-deps/debathena-language-support: debian/deps |
---|
| 19 | cat $< >> debian/$(cdbs_curpkg).substvars |
---|
| 20 | |
---|
| 21 | clean:: |
---|
| 22 | rm -f $(APTITUDE_LOCKFILE) debian/deps |
---|
Note: See
TracBrowser
for help on using the repository browser.