source: trunk/debathena/meta/locker/debian/rules @ 25709

Revision 25709, 349 bytes checked in by jdreed, 12 years ago (diff)
In locker: * Sigh. Depend on a specific version of libperl4-corelibs-perl, because upstream decided it was a good idea for perl-modules to Provide: this package in the interim. In theory, we don't care, and things will work when Ubuntu actually drops perl4 support, but in reality, it causes confusing errors for users. (Trac: #1188)
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3HAVE_PERL4LIBS = $(shell apt-cache show libperl4-corelibs-perl 2>/dev/null | grep -q '^Version:' && echo y)
4
5ifeq ($(HAVE_PERL4LIBS),y)
6    binary-predeb/debathena-locker::
7        echo "debathena-maybe-perl4=libperl4-corelibs-perl (>= 0.003-1~)" >> debian/debathena-locker.substvars
8endif
9
10include /usr/share/cdbs/1/rules/debhelper.mk
Note: See TracBrowser for help on using the repository browser.