Revision 25219,
703 bytes
checked in by jdreed, 12 years ago
(diff) |
Fix rules again, because thunderbird is referred to so will show
up in apt-cache policy as "(none)" instead of the empty string
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[25153] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
[25219] | 3 | TBIRD_VERSION = $(shell apt-cache policy thunderbird 2>/dev/null | awk '/^ Candidate/ { print $$2 }' | fgrep -vx '(none)') |
---|
[25215] | 4 | TBIRD_3_1 = $(shell dpkg --compare-versions '$(TBIRD_VERSION)' ge '3.1~' && echo y) |
---|
[25217] | 5 | ICED_VERSION = $(shell apt-cache policy icedove 2>/dev/null | awk '/^ Can\ |
---|
[25219] | 6 | didate/ { print $$2 }' | fgrep -vx '(none)') |
---|
[25217] | 7 | ICED_3_1 = $(shell dpkg --compare-versions '$(ICED_VERSION)' ge '3.1~' && ech\ |
---|
| 8 | o y) |
---|
[25153] | 9 | |
---|
| 10 | ifneq ($(TBIRD_3_1),y) |
---|
[25217] | 11 | ifneq ($(ICED_3_1),y) |
---|
| 12 | binary-predeb/debathena-login-graphical:: |
---|
| 13 | echo "debathena-thunderbird-config-recommends=debathena-thunderbird-config" >> debian/debathena-login-graphical.substvars |
---|
[25153] | 14 | endif |
---|
[25217] | 15 | endif |
---|
[25153] | 16 | |
---|
| 17 | |
---|
| 18 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
Note: See
TracBrowser
for help on using the repository browser.