source: trunk/debathena/meta/login-graphical/debian/rules @ 25219

Revision 25219, 703 bytes checked in by jdreed, 13 years ago (diff)
Fix rules again, because thunderbird is referred to so will show up in apt-cache policy as "(none)" instead of the empty string
  • Property svn:executable set to *
RevLine 
[25153]1#!/usr/bin/make -f
2
[25219]3TBIRD_VERSION = $(shell apt-cache policy thunderbird 2>/dev/null | awk '/^  Candidate/ { print $$2 }' | fgrep -vx '(none)')
[25215]4TBIRD_3_1 = $(shell dpkg --compare-versions '$(TBIRD_VERSION)' ge '3.1~' && echo y)
[25217]5ICED_VERSION = $(shell apt-cache policy icedove 2>/dev/null | awk '/^  Can\
[25219]6didate/ { print $$2 }' | fgrep -vx '(none)')
[25217]7ICED_3_1 = $(shell dpkg --compare-versions '$(ICED_VERSION)' ge '3.1~' && ech\
8o y)
[25153]9
10ifneq ($(TBIRD_3_1),y)
[25217]11ifneq ($(ICED_3_1),y)
12binary-predeb/debathena-login-graphical::
13        echo "debathena-thunderbird-config-recommends=debathena-thunderbird-config" >> debian/debathena-login-graphical.substvars
[25153]14endif
[25217]15endif
[25153]16
17
18include /usr/share/cdbs/1/rules/debhelper.mk
Note: See TracBrowser for help on using the repository browser.