Revision 25219,
703 bytes
checked in by jdreed, 13 years ago
(diff) |
Fix rules again, because thunderbird is referred to so will show
up in apt-cache policy as "(none)" instead of the empty string
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | TBIRD_VERSION = $(shell apt-cache policy thunderbird 2>/dev/null | awk '/^ Candidate/ { print $$2 }' | fgrep -vx '(none)') |
---|
4 | TBIRD_3_1 = $(shell dpkg --compare-versions '$(TBIRD_VERSION)' ge '3.1~' && echo y) |
---|
5 | ICED_VERSION = $(shell apt-cache policy icedove 2>/dev/null | awk '/^ Can\ |
---|
6 | didate/ { print $$2 }' | fgrep -vx '(none)') |
---|
7 | ICED_3_1 = $(shell dpkg --compare-versions '$(ICED_VERSION)' ge '3.1~' && ech\ |
---|
8 | o y) |
---|
9 | |
---|
10 | ifneq ($(TBIRD_3_1),y) |
---|
11 | ifneq ($(ICED_3_1),y) |
---|
12 | binary-predeb/debathena-login-graphical:: |
---|
13 | echo "debathena-thunderbird-config-recommends=debathena-thunderbird-config" >> debian/debathena-login-graphical.substvars |
---|
14 | endif |
---|
15 | endif |
---|
16 | |
---|
17 | |
---|
18 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
Note: See
TracBrowser
for help on using the repository browser.