source: trunk/debathena/meta/login-graphical/debian/rules @ 25531

Revision 25531, 1.1 KB checked in by jdreed, 12 years ago (diff)
In login-graphical: * Maybe depend on lightdm-config.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3TBIRD_VERSION = $(shell apt-cache policy thunderbird 2>/dev/null | awk '/^  Candidate/ { print $$2 }' | fgrep -vx '(none)')
4TBIRD_3_1 = $(shell dpkg --compare-versions '$(TBIRD_VERSION)' ge '3.1~' && echo y)
5ICED_VERSION = $(shell apt-cache policy icedove 2>/dev/null | awk '/^  Candidate/ { print $$2 }' | fgrep -vx '(none)')
6ICED_3_1 = $(shell dpkg --compare-versions '$(ICED_VERSION)' ge '3.1~' && ech\
7o y)
8LIGHTDM_VERSION = $(shell apt-cache policy lightdm 2>/dev/null | awk '/^  Candidate/ { print $$2 }' | fgrep -vx '(none)')
9HAVE_LIGHTDM_106 = $(shell dpkg --compare-versions '$(LIGHTDM_VERSION)' ge '1.0.6~' && echo y)
10
11ifneq ($(TBIRD_3_1),y)
12ifneq ($(ICED_3_1),y)
13binary-predeb/debathena-login-graphical::
14        echo "debathena-thunderbird-config-recommends=debathena-thunderbird-config" >> debian/debathena-login-graphical.substvars
15endif
16endif
17
18ifeq ($(HAVE_LIGHTDM_106),y)
19binary-predeb/debathena-login-graphical::
20        echo "debathena-maybe-lightdm-config=debathena-lightdm-config" >> debian/debathena-login-graphical.substvars
21endif
22
23
24include /usr/share/cdbs/1/rules/debhelper.mk
Note: See TracBrowser for help on using the repository browser.