Revision 25531,
1.1 KB
checked in by jdreed, 12 years ago
(diff) |
In login-graphical:
* Maybe depend on lightdm-config.
|
-
Property svn:executable set to
*
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | TBIRD_VERSION = $(shell apt-cache policy thunderbird 2>/dev/null | awk '/^ Candidate/ { print $$2 }' | fgrep -vx '(none)') |
---|
4 | TBIRD_3_1 = $(shell dpkg --compare-versions '$(TBIRD_VERSION)' ge '3.1~' && echo y) |
---|
5 | ICED_VERSION = $(shell apt-cache policy icedove 2>/dev/null | awk '/^ Candidate/ { print $$2 }' | fgrep -vx '(none)') |
---|
6 | ICED_3_1 = $(shell dpkg --compare-versions '$(ICED_VERSION)' ge '3.1~' && ech\ |
---|
7 | o y) |
---|
8 | LIGHTDM_VERSION = $(shell apt-cache policy lightdm 2>/dev/null | awk '/^ Candidate/ { print $$2 }' | fgrep -vx '(none)') |
---|
9 | HAVE_LIGHTDM_106 = $(shell dpkg --compare-versions '$(LIGHTDM_VERSION)' ge '1.0.6~' && echo y) |
---|
10 | |
---|
11 | ifneq ($(TBIRD_3_1),y) |
---|
12 | ifneq ($(ICED_3_1),y) |
---|
13 | binary-predeb/debathena-login-graphical:: |
---|
14 | echo "debathena-thunderbird-config-recommends=debathena-thunderbird-config" >> debian/debathena-login-graphical.substvars |
---|
15 | endif |
---|
16 | endif |
---|
17 | |
---|
18 | ifeq ($(HAVE_LIGHTDM_106),y) |
---|
19 | binary-predeb/debathena-login-graphical:: |
---|
20 | echo "debathena-maybe-lightdm-config=debathena-lightdm-config" >> debian/debathena-login-graphical.substvars |
---|
21 | endif |
---|
22 | |
---|
23 | |
---|
24 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
Note: See
TracBrowser
for help on using the repository browser.