Revision 25478,
687 bytes
checked in by jdreed, 12 years ago
(diff) |
In syslog:
* Deal with multi-arch by only accepting the first line aptitude
returns, and stripping out any arch component that may be there
|
-
Property svn:executable set to
*
|
Rev | Line | |
---|
[24240] | 1 | #!/usr/bin/make -f |
---|
| 2 | |
---|
| 3 | include /usr/share/cdbs/1/rules/debhelper.mk |
---|
| 4 | |
---|
[24243] | 5 | APTITUDE_LOCKFILE = $(CURDIR)/debian/aptitude-lockfile |
---|
| 6 | APTITUDE = aptitude -o 'Aptitude::LockFile=$(APTITUDE_LOCKFILE)' -o 'Debug::NoLocking=yes' |
---|
[24244] | 7 | |
---|
| 8 | common-build-indep:: debian/deps |
---|
| 9 | |
---|
| 10 | debian/deps: |
---|
| 11 | echo -n "debathena-syslog-depends=" > $@ |
---|
[25478] | 12 | $(APTITUDE) search '~Psystem-log-daemon~pimportant' -F '%p' | cut -d ':' -f 1 | head -1 >> $@ |
---|
[24244] | 13 | echo >> $@ |
---|
| 14 | |
---|
[25473] | 15 | # DEFAULT_SYSLOG = $(shell $(APTITUDE) search -F"%p" ~Psystem-log-daemon~pimportant) |
---|
[24240] | 16 | |
---|
[24244] | 17 | binary-predeb/debathena-syslog:: add-deps/debathena-syslog |
---|
[24240] | 18 | |
---|
[24244] | 19 | add-deps/debathena-syslog: debian/deps |
---|
| 20 | cat $< >> debian/$(cdbs_curpkg).substvars |
---|
| 21 | |
---|
| 22 | clean:: |
---|
| 23 | rm -f $(APTITUDE_LOCKFILE) debian/deps |
---|
Note: See
TracBrowser
for help on using the repository browser.