source: trunk/debathena/meta/syslog/debian/rules @ 24244

Revision 24244, 657 bytes checked in by broder, 14 years ago (diff)
Fix some problems with aptitude file permissions in debathena-syslog by stealing similar logic from debathena-language-support.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3include /usr/share/cdbs/1/rules/debhelper.mk
4
5APTITUDE_LOCKFILE = $(CURDIR)/debian/aptitude-lockfile
6APTITUDE = aptitude -o 'Aptitude::LockFile=$(APTITUDE_LOCKFILE)' -o 'Debug::NoLocking=yes'
7
8common-build-indep:: debian/deps
9
10debian/deps:
11        echo -n "debathena-syslog-depends=" > $@
12        $(APTITUDE) search '~Psystem-log-daemon~pimportant' -F '%p' >> $@
13        echo >> $@
14
15DEFAULT_SYSLOG = $(shell $(APTITUDE) search -F"%p" ~Psystem-log-daemon~pimportant)
16
17binary-predeb/debathena-syslog:: add-deps/debathena-syslog
18
19add-deps/debathena-syslog: debian/deps
20        cat $< >> debian/$(cdbs_curpkg).substvars
21
22clean::
23        rm -f $(APTITUDE_LOCKFILE) debian/deps
Note: See TracBrowser for help on using the repository browser.