source: trunk/debathena/scripts/check-unbuilt-packages @ 24874

Revision 24874, 416 bytes checked in by geofft, 11 years ago (diff)
Add a script to check for apt being out of date with respect to svn
  • Property svn:executable set to *
Line 
1#!/bin/sh
2
3while read package path; do
4    svnversion=$(svn cat svn+ssh://svn.mit.edu/athena/trunk/"$path"/debian/changelog | dpkg-parsechangelog -l- | sed -n 's/^Version: //p')
5    aptversion=$(apt-cache showsrc "$package" | sed -n 's/^Version: //p')
6    if [ "$svnversion" != "$aptversion" ]; then
7        echo "$package is $svnversion in svn and $aptversion in apt"
8    fi
9done < /mit/debathena/packages/packages
Note: See TracBrowser for help on using the repository browser.