source: trunk/debathena/third/alpine/alpine-1.00-krb5-configure.patch @ 23068

Revision 23068, 795 bytes checked in by ghudson, 16 years ago (diff)
Add a debathenify script for alpine. Currently only works for hardy and lenny.
RevLine 
[23068]1--- alpine/configure.ac (revision 899)
2+++ alpine/configure.ac (revision 900)
3@@ -940,10 +940,24 @@
4 
5 dnl provide KRB5 support?
6 if test "x$alpine_GSSTYPE" != "xnone" ; then
7-  AC_CHECK_FUNC(gss_init_sec_context,,
8+  AC_SEARCH_LIBS(gss_init_sec_context,gss gssapi gssapi_krb5,
9     [
10+      dnl MIT-based?
11+      AC_CHECK_HEADER([gssapi/gssapi_generic.h],,
12+       [
13+         if test ! -d /usr/kerberos/include ; then
14+           alpine_GSSTYPE="none"
15+           alpine_gss_none_reason="header files not found"
16+         fi
17+       ])
18+    ],
19+    [
20       alpine_GSSTYPE="none"
21+      alpine_gss_none_reason="libraries not found"
22     ])
23+  if test -n "$alpine_gss_none_reason" ; then
24+    AC_MSG_NOTICE([NOT including Kerberos Support: $alpine_gss_none_reason])
25+  fi
26 fi
27 
28 dnl check for tcl libraries for Web Alpine (HACKY)
Note: See TracBrowser for help on using the repository browser.