source: trunk/third/GConf2/gconf.spec @ 18568

Revision 18568, 2.9 KB checked in by ghudson, 22 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18567, which included commits to RCS files with non-trunk default branches.
Line 
1#
2# Note that this is NOT a relocatable package
3# $Id: gconf.spec,v 1.1.1.2 2003-01-29 20:00:20 ghudson Exp $
4#
5%define ver      2.2.0
6%define rel      1
7%define prefix   %{_prefix}
8%define name     GConf
9%define sysconfdir      /etc
10
11Summary: Gnome Config System
12Name: %name
13Version: %ver
14Release: %rel
15Copyright: LGPL
16Group: System Environment/Base
17Source: ftp://ftp.gnome.org/pub/GNOME/unstable/sources/GConf/GConf-%{ver}.tar.gz
18BuildRoot: /var/tmp/gconf-root
19Packager: Eskil Heyn Olsen <eskil@eazel.com>
20URL: http://www.gnome.org/
21Prereq: /sbin/install-info
22Prefix: %{prefix}
23Docdir: %{prefix}/doc
24Requires: glib >= 1.2.0
25Requires: oaf >= 0.3.0
26Requires: gtk+ >= 1.2.0
27Requires: ORBit >= 0.5.0
28Requires: libxml >= 1.8.0
29
30%description
31GConf is the GNOME Configuration database system.
32
33GNOME is the GNU Network Object Model Environment.  That's a fancy
34name but really GNOME is a nice GUI desktop environment.  It makes
35using your computer easy, powerful, and easy to configure.
36
37%package devel
38Summary: Gnome Config System development package
39Group: Development/Libraries
40Requires: %name = %{ver}
41Requires: ORBit-devel
42Requires: glib-devel
43Requires: oaf-devel
44Requires: gtk+-devel
45PreReq: /sbin/install-info
46
47%description devel
48GConf development package. Contains files needed for doing
49development using GConf.
50
51%changelog
52
53* Sat Oct 13 2001 Ross Golder <ross@golder.org>
54- Updated to reflect installation path changes
55
56* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
57- Created the .spec file
58
59%prep
60%setup
61
62%build
63# Needed for snapshot releases.
64if [ ! -f configure ]; then
65  CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%prefix --sysconfdir=%{sysconfdir}
66else
67  CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%prefix --sysconfdir=%{sysconfdir}
68fi
69
70if [ "$SMP" != "" ]; then
71  (make "MAKE=make -k -j $SMP"; exit 0)
72  make
73else
74  make
75fi
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(-, root, root)
90%doc AUTHORS COPYING ChangeLog NEWS README
91%config(noreplace) %{sysconfdir}/gconf/2/path
92%config(noreplace) %{sysconfdir}/gconf/schemas/*.schemas
93%dir    %{sysconfdir}/gconf/gconf.xml.defaults
94%dir    %{sysconfdir}/gconf/gconf.xml.mandatory
95%{prefix}/libexec/gconfd-2
96%{prefix}/bin/gconftool
97%{prefix}/bin/gconftool-2
98%{prefix}/lib/lib*.so.*
99%{prefix}/lib/GConf/2/*.so
100%{prefix}/lib/pkgconfig/*.pc
101%{prefix}/share/locale/*/LC_MESSAGES/*.mo
102%{prefix}/share/gconf/2
103
104
105## /etc/gconf/schemas/desktop.schemas is notably missing;
106## it will be shared between versions of GConf, preventing
107## simulataneous installation, so maybe should be in
108## a different (minuscule) package.
109
110%files devel
111%defattr(-, root, root)
112%{prefix}/lib/*.a
113%{prefix}/lib/*.la
114%{prefix}/lib/*.so
115#%{prefix}/lib/GConf/2/*.a
116#%{prefix}/lib/GConf/2/*.la
117%{prefix}/include/gconf/2/gconf/*.h
118%{prefix}/share/aclocal/*.m4
Note: See TracBrowser for help on using the repository browser.