1 | %define ver 0.5.4 |
---|
2 | %define RELEASE 1 |
---|
3 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
4 | %define prefix /usr |
---|
5 | |
---|
6 | Summary: High-performance CORBA Object Request Broker. |
---|
7 | Name: ORBit |
---|
8 | Version: %ver |
---|
9 | Release: %rel |
---|
10 | Source: ftp://ftp.labs.redhat.com/pub/ORBit/ORBit-%{PACKAGE_VERSION}.tar.gz |
---|
11 | Group: System Environment/Libraries |
---|
12 | Copyright: LGPL/GPL |
---|
13 | BuildRoot: /var/tmp/orbit-%{PACKAGE_VERSION}-root |
---|
14 | Prefix: %{prefix} |
---|
15 | Docdir: %{prefix}/doc |
---|
16 | Prereq: /sbin/install-info |
---|
17 | URL: http://www.labs.redhat.com/orbit/ |
---|
18 | |
---|
19 | %description |
---|
20 | ORBit is a high-performance CORBA (Common Object Request Broker |
---|
21 | Architecture) ORB (object request broker). It allows programs to |
---|
22 | send requests and receive replies from other programs, regardless |
---|
23 | of the locations of the two programs. CORBA is an architecture that |
---|
24 | enables communication between program objects, regardless of the |
---|
25 | programming language they're written in or the operating system they |
---|
26 | run on. |
---|
27 | |
---|
28 | You will need to install this package if you want to run programs that use |
---|
29 | the ORBit implementation of CORBA technology. |
---|
30 | |
---|
31 | %package devel |
---|
32 | Summary: Development libraries, header files and utilities for ORBit. |
---|
33 | Group: Development/Libraries |
---|
34 | Requires: indent |
---|
35 | Requires: glib-devel |
---|
36 | Requires: ORBit = %{ver} |
---|
37 | |
---|
38 | %description devel |
---|
39 | This package contains the header files, libraries and utilities |
---|
40 | necessary to write programs that use CORBA technology. If you want to |
---|
41 | write such programs, you'll also need to install the ORBit package. |
---|
42 | |
---|
43 | %prep |
---|
44 | %setup |
---|
45 | |
---|
46 | %build |
---|
47 | # Needed for snapshot releases. |
---|
48 | #MYCFLAGS="-DG_DISABLE_ASSERT -DG_DISABLE_CHECKS $RPM_OPT_FLAGS" |
---|
49 | MYCFLAGS="$RPM_OPT_FLAGS" |
---|
50 | if [ ! -f configure ]; then |
---|
51 | CFLAGS="$MYCFLAGS" ./autogen.sh --prefix=%prefix |
---|
52 | else |
---|
53 | CFLAGS="$MYCFLAGS" ./configure --prefix=%prefix |
---|
54 | fi |
---|
55 | make |
---|
56 | |
---|
57 | %install |
---|
58 | rm -rf $RPM_BUILD_ROOT |
---|
59 | mkdir -p $RPM_BUILD_ROOT%{prefix} |
---|
60 | make prefix=$RPM_BUILD_ROOT%{prefix} install |
---|
61 | |
---|
62 | /sbin/ldconfig -n $RPM_BUILD_ROOT%{prefix}/lib |
---|
63 | |
---|
64 | strip $RPM_BUILD_ROOT%{prefix}/bin/* || : |
---|
65 | |
---|
66 | gzip -9 $RPM_BUILD_ROOT%{prefix}/info/* |
---|
67 | |
---|
68 | %post -p /sbin/ldconfig |
---|
69 | |
---|
70 | %postun -p /sbin/ldconfig |
---|
71 | |
---|
72 | %post devel |
---|
73 | /sbin/install-info %{prefix}/info/libIDL.info.gz %{prefix}/info/dir |
---|
74 | |
---|
75 | %preun devel |
---|
76 | if [ $1 = 0 ]; then |
---|
77 | /sbin/install-info --delete %{prefix}/info/libIDL.info.gz %{prefix}/info/dir |
---|
78 | fi |
---|
79 | |
---|
80 | %clean |
---|
81 | rm -rf $RPM_BUILD_ROOT |
---|
82 | |
---|
83 | %files |
---|
84 | %defattr(-,root,root) |
---|
85 | |
---|
86 | %doc AUTHORS COPYING ChangeLog NEWS README TODO |
---|
87 | %doc -P libIDL/COPYING libIDL/ChangeLog libIDL/AUTHORS |
---|
88 | %doc -P libIDL/README* libIDL/NEWS libIDL/BUGS libIDL/tstidl.c |
---|
89 | |
---|
90 | %{prefix}/lib/lib*.so.* |
---|
91 | %{prefix}/bin/orbit-event-server |
---|
92 | %{prefix}/bin/orbit-name-server |
---|
93 | #don't install old-name-server |
---|
94 | #%{prefix}/bin/old-name-server |
---|
95 | %{prefix}/bin/name-client |
---|
96 | %{prefix}/bin/orbit-ird |
---|
97 | |
---|
98 | %files devel |
---|
99 | %{prefix}/bin/orbit-idl |
---|
100 | %{prefix}/bin/orbit-config |
---|
101 | %{prefix}/bin/libIDL-config |
---|
102 | %{prefix}/include/* |
---|
103 | %{prefix}/info/libIDL.info.gz |
---|
104 | %{prefix}/lib/*.sh |
---|
105 | %{prefix}/lib/lib*.a |
---|
106 | %{prefix}/lib/lib*.so |
---|
107 | %{prefix}/share/aclocal/* |
---|
108 | |
---|
109 | %changelog |
---|
110 | * Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.4.94-1 |
---|
111 | - Spec file fixes from RHL 6.0. |
---|
112 | |
---|
113 | * Wed Jun 2 1999 Jose Mercado <jmercado@mit.edu> |
---|
114 | - Fixed configure.in so spec.in could be used. |
---|
115 | |
---|
116 | * Mon Nov 23 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch> |
---|
117 | |
---|
118 | - improved %files section, and added use of %{prefix} and install-info |
---|
119 | (well,... no. The info file has not dir info inside, commented out) |
---|