1 | Summary: ACME the Versatile Keyboard daemon |
---|
2 | Name: acme |
---|
3 | Version: 2.0.2 |
---|
4 | Release: 1 |
---|
5 | |
---|
6 | Group: System Environment/Daemons |
---|
7 | License: GPL |
---|
8 | URL: http://www.hadess.net/misc-code.php3 |
---|
9 | Source: %{name}-%{version}.tar.gz |
---|
10 | BuildRoot: %{_tmppath}/%{name}-root |
---|
11 | |
---|
12 | Requires: libgnomeui >= 2.0.0 |
---|
13 | Requires: libglade2 >= 2.0.0 |
---|
14 | BuildRequires: libgnomeui-devel >= 2.0.0 |
---|
15 | BuildRequires: libglade2-devel >= 2.0.0 |
---|
16 | BuildRequires: gob2 |
---|
17 | |
---|
18 | %description |
---|
19 | ACME is a small GNOME tool to make use of the multimedia buttons present on |
---|
20 | most laptops and internet keyboards: Volume, Brightness, Power, Eject, My Home, |
---|
21 | Search, E-Mail, Sleep, Screensaver, Finance and Help buttons. |
---|
22 | %prep |
---|
23 | %setup -q |
---|
24 | |
---|
25 | %build |
---|
26 | if [ ! -f configure ]; then |
---|
27 | CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=/usr --enable-shared |
---|
28 | else |
---|
29 | CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=/usr --enable-shared |
---|
30 | fi |
---|
31 | |
---|
32 | export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 |
---|
33 | make |
---|
34 | |
---|
35 | %install |
---|
36 | [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
---|
37 | |
---|
38 | %makeinstall |
---|
39 | |
---|
40 | %clean |
---|
41 | [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
---|
42 | |
---|
43 | %post |
---|
44 | export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` |
---|
45 | gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/acme.schemas > /dev/null |
---|
46 | |
---|
47 | %postun |
---|
48 | /sbin/ldconfig |
---|
49 | |
---|
50 | %files |
---|
51 | %defattr(644,root,root,755) |
---|
52 | %attr(755,root,root) %{_bindir}/* |
---|
53 | %{_datadir}/acme/* |
---|
54 | %{_datadir}/control-center-2.0/capplets/* |
---|
55 | %{_datadir}/locale/*/*/* |
---|
56 | %{_sysconfdir}/gconf/schemas/acme.schemas |
---|
57 | |
---|
58 | %changelog |
---|
59 | * Thu Oct 31 2002 Thomas Vander Stichele <thomas at apestaart dot org> |
---|
60 | - fix requires and buildrequires |
---|
61 | |
---|
62 | * Mon Sep 23 2002 Bastien Nocera <hadess@hadess.net> |
---|
63 | - More hacking |
---|
64 | |
---|
65 | * Mon Sep 23 2002 Christian Fredrik Kalager Schaller <Uraeus@linuxrising.org> |
---|
66 | - First attempt at SPEC |
---|