1 | # Note that this is NOT a relocatable package |
---|
2 | %define name eel |
---|
3 | %define ver 1.0.2 |
---|
4 | %define RELEASE 0_cvs_0 |
---|
5 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
6 | %define prefix /usr |
---|
7 | %define sysconfdir /etc |
---|
8 | |
---|
9 | Name: %name |
---|
10 | Vendor: GNOME |
---|
11 | Distribution: CVS |
---|
12 | Summary: Eazel Extensions Library |
---|
13 | Version: %ver |
---|
14 | Release: %rel |
---|
15 | Copyright: GPL |
---|
16 | Group: System Environment/Libraries |
---|
17 | Source: %{name}-%{ver}.tar.gz |
---|
18 | URL: http://nautilus.eazel.com/ |
---|
19 | BuildRoot: /var/tmp/%{name}-%{ver}-root |
---|
20 | Docdir: %{prefix}/doc |
---|
21 | Requires: glib >= 1.2.9 |
---|
22 | Requires: gtk+ >= 1.2.9 |
---|
23 | Requires: libxml >= 1.8.10 |
---|
24 | Requires: gnome-libs >= 1.2.11 |
---|
25 | Requires: gnome-vfs >= 1.0 |
---|
26 | Requires: gdk-pixbuf >= 0.10.0 |
---|
27 | Requires: freetype >= 2.0.1 |
---|
28 | Requires: libpng |
---|
29 | Requires: GConf >= 0.12 |
---|
30 | Requires: oaf >= 0.6.5 |
---|
31 | Requires: librsvg >= 1.0.0 |
---|
32 | |
---|
33 | BuildRequires: glib-devel >= 1.2.9 |
---|
34 | BuildRequires: gtk+-devel >= 1.2.9 |
---|
35 | BuildRequires: libxml-devel >= 1.8.10 |
---|
36 | BuildRequires: gnome-libs-devel >= 1.2.11 |
---|
37 | BuildRequires: GConf-devel >= 0.12 |
---|
38 | BuildRequires: oaf-devel >= 0.6.5 |
---|
39 | BuildRequires: gnome-vfs-devel >= 1.0 |
---|
40 | BuildRequires: gdk-pixbuf-devel >= 0.10.0 |
---|
41 | BuildRequires: libpng-devel |
---|
42 | BuildRequires: librsvg-devel >= 1.0.0 |
---|
43 | |
---|
44 | %description |
---|
45 | Eazel Extensions Library |
---|
46 | |
---|
47 | %package devel |
---|
48 | Summary: Libraries and include files for developing with Eel. |
---|
49 | Group: Development/Libraries |
---|
50 | Requires: %name = %{PACKAGE_VERSION} |
---|
51 | |
---|
52 | %description devel |
---|
53 | This package provides the necessary development libraries and include |
---|
54 | files to allow you to develop with Eel. |
---|
55 | |
---|
56 | %changelog |
---|
57 | * Wed Apr 04 2000 Ramiro Estrugo <ramiro@eazel.com> |
---|
58 | - created this thing |
---|
59 | |
---|
60 | %prep |
---|
61 | %setup |
---|
62 | |
---|
63 | %build |
---|
64 | %ifarch alpha |
---|
65 | MYARCH_FLAGS="--host=alpha-redhat-linux" |
---|
66 | %endif |
---|
67 | |
---|
68 | LC_ALL="" |
---|
69 | LINGUAS="" |
---|
70 | LANG="" |
---|
71 | export LC_ALL LINGUAS LANG |
---|
72 | |
---|
73 | ## Warning! Make sure there are no spaces or tabs after the \ |
---|
74 | ## continuation character, or else the rpm demons will eat you. |
---|
75 | CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS --prefix=%{prefix} \ |
---|
76 | --sysconfdir=%{sysconfdir} |
---|
77 | |
---|
78 | make -k |
---|
79 | make check |
---|
80 | |
---|
81 | %install |
---|
82 | [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT |
---|
83 | make -k prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install |
---|
84 | for FILE in "$RPM_BUILD_ROOT/bin/*"; do |
---|
85 | file "$FILE" | grep -q not\ stripped && strip $FILE |
---|
86 | done |
---|
87 | |
---|
88 | %clean |
---|
89 | [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT |
---|
90 | |
---|
91 | %post |
---|
92 | if ! grep %{prefix}/lib /etc/ld.so.conf > /dev/null ; then |
---|
93 | echo "%{prefix}/lib" >> /etc/ld.so.conf |
---|
94 | fi |
---|
95 | /sbin/ldconfig |
---|
96 | |
---|
97 | %postun -p /sbin/ldconfig |
---|
98 | |
---|
99 | %files |
---|
100 | |
---|
101 | %defattr(0555, bin, bin) |
---|
102 | %doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README |
---|
103 | %{_libdir}/*.so* |
---|
104 | |
---|
105 | %defattr (0444, bin, bin) |
---|
106 | %{_datadir}/locale/*/LC_MESSAGES/*.mo |
---|
107 | %{_datadir}/eel/fonts/urw/*.dir |
---|
108 | %{_datadir}/eel/fonts/urw/*.pfb |
---|
109 | %{_datadir}/eel/fonts/urw/*.afm |
---|
110 | %{_datadir}/eel/fonts/urw/*.pfm |
---|
111 | |
---|
112 | %files devel |
---|
113 | |
---|
114 | %defattr(0555, bin, bin) |
---|
115 | %{_libdir}/*.la |
---|
116 | %{_libdir}/*.sh |
---|
117 | %{_bindir}/eel-config |
---|
118 | |
---|
119 | %defattr(0444, bin, bin) |
---|
120 | %{_includedir}/eel-1/eel/*.h |
---|