source: trunk/third/eel/eel.spec @ 17274

Revision 17274, 2.8 KB checked in by amb, 23 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r17273, which included commits to RCS files with non-trunk default branches.
Line 
1# Note that this is NOT a relocatable package
2%define name            eel
3%define ver             1.0.2
4%define RELEASE         0_cvs_0
5%define rel             %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
6%define prefix          /usr
7%define sysconfdir      /etc
8
9Name:           %name
10Vendor:         GNOME
11Distribution:   CVS
12Summary:        Eazel Extensions Library
13Version:        %ver
14Release:        %rel
15Copyright:      GPL
16Group:          System Environment/Libraries
17Source:         %{name}-%{ver}.tar.gz
18URL:            http://nautilus.eazel.com/
19BuildRoot:      /var/tmp/%{name}-%{ver}-root
20Docdir:         %{prefix}/doc
21Requires:       glib >= 1.2.9
22Requires:       gtk+ >= 1.2.9
23Requires:       libxml >= 1.8.10
24Requires:       gnome-libs >= 1.2.11
25Requires:       gnome-vfs >= 1.0
26Requires:       gdk-pixbuf >= 0.10.0
27Requires:       freetype >= 2.0.1
28Requires:       libpng
29Requires:       GConf >= 0.12
30Requires:       oaf >= 0.6.5
31Requires:       librsvg >= 1.0.0
32
33BuildRequires:  glib-devel >= 1.2.9
34BuildRequires:  gtk+-devel >= 1.2.9
35BuildRequires:  libxml-devel >= 1.8.10
36BuildRequires:  gnome-libs-devel >= 1.2.11
37BuildRequires:  GConf-devel >= 0.12
38BuildRequires:  oaf-devel >= 0.6.5
39BuildRequires:  gnome-vfs-devel >= 1.0
40BuildRequires:  gdk-pixbuf-devel >= 0.10.0
41BuildRequires:  libpng-devel
42BuildRequires:  librsvg-devel >= 1.0.0
43
44%description
45Eazel Extensions Library
46
47%package devel
48Summary:        Libraries and include files for developing with Eel.
49Group:          Development/Libraries
50Requires:       %name = %{PACKAGE_VERSION}
51
52%description devel
53This package provides the necessary development libraries and include
54files to allow you to develop with Eel.
55
56%changelog
57* Wed Apr 04 2000 Ramiro Estrugo <ramiro@eazel.com>
58- created this thing
59
60%prep
61%setup
62
63%build
64%ifarch alpha
65        MYARCH_FLAGS="--host=alpha-redhat-linux"
66%endif
67
68LC_ALL=""
69LINGUAS=""
70LANG=""
71export LC_ALL LINGUAS LANG
72
73## Warning!  Make sure there are no spaces or tabs after the \
74## continuation character, or else the rpm demons will eat you.
75CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS --prefix=%{prefix} \
76        --sysconfdir=%{sysconfdir}
77
78make -k
79make check
80
81%install
82[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
83make -k prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install
84for FILE in "$RPM_BUILD_ROOT/bin/*"; do
85        file "$FILE" | grep -q not\ stripped && strip $FILE
86done
87
88%clean
89[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
90
91%post
92if ! grep %{prefix}/lib /etc/ld.so.conf > /dev/null ; then
93        echo "%{prefix}/lib" >> /etc/ld.so.conf
94fi
95/sbin/ldconfig
96
97%postun -p /sbin/ldconfig
98
99%files
100
101%defattr(0555, bin, bin)
102%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
103%{_libdir}/*.so*
104
105%defattr (0444, bin, bin)
106%{_datadir}/locale/*/LC_MESSAGES/*.mo
107%{_datadir}/eel/fonts/urw/*.dir
108%{_datadir}/eel/fonts/urw/*.pfb
109%{_datadir}/eel/fonts/urw/*.afm
110%{_datadir}/eel/fonts/urw/*.pfm
111
112%files devel
113
114%defattr(0555, bin, bin)
115%{_libdir}/*.la
116%{_libdir}/*.sh
117%{_bindir}/eel-config
118
119%defattr(0444, bin, bin)
120%{_includedir}/eel-1/eel/*.h
Note: See TracBrowser for help on using the repository browser.