1 | # |
---|
2 | # Note that this is NOT a relocatable package |
---|
3 | # |
---|
4 | |
---|
5 | %define ver 2.8.2 |
---|
6 | %define rel 1 |
---|
7 | %define prefix /usr |
---|
8 | %define name eog |
---|
9 | |
---|
10 | Summary: Eye Of Gnome |
---|
11 | Name: %name |
---|
12 | Version: %ver |
---|
13 | Release: %rel |
---|
14 | Copyright: GPL |
---|
15 | Group: Applications/Multimedia |
---|
16 | Source: ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/eog-%{ver}.tar.gz |
---|
17 | BuildRoot: /var/tmp/eog |
---|
18 | Obsoletes: eog |
---|
19 | Packager: Federico Mena-Quintero <federico@gnu.org> |
---|
20 | URL: http://www.gnome.org |
---|
21 | Prereq: /sbin/install-info |
---|
22 | Prefix: %{prefix} |
---|
23 | Docdir: %{prefix}/doc |
---|
24 | Requires: ORBit >= 0.5.0 |
---|
25 | Requires: oaf >= 0.3.0 |
---|
26 | Requires: gnome-print >= 0.20 |
---|
27 | Requires: gdk-pixbuf >= 0.9.0 |
---|
28 | Requires: bonobo >= 0.15 |
---|
29 | Requires: gconf >= 0.8 |
---|
30 | |
---|
31 | %description |
---|
32 | This is the Eye of Gnome, an image viewer program. It is meant to be |
---|
33 | a fast and functional image viewer as well as an image cataloging |
---|
34 | program. |
---|
35 | |
---|
36 | %changelog |
---|
37 | |
---|
38 | * Mon Sep 04 2000 Federico Mena Quintero <federico@helixcode.com> |
---|
39 | |
---|
40 | - Updated the spec file; it is still not guaranteed to work out of the |
---|
41 | box. |
---|
42 | |
---|
43 | |
---|
44 | * Sun Jun 11 2000 Eskil Heyn Olsen <deity@eazel.com> |
---|
45 | |
---|
46 | - Created the .spec file |
---|
47 | |
---|
48 | %prep |
---|
49 | %setup |
---|
50 | |
---|
51 | %build |
---|
52 | # Needed for snapshot releases. |
---|
53 | if [ ! -f configure ]; then |
---|
54 | CFLAGS="-pipe $RPM_OPT_FLAGS" ./autogen.sh \ |
---|
55 | --prefix=%{prefix} --sysconfdir=%{sysconfdir} \ |
---|
56 | --localstatedir=%{localstatedir} |
---|
57 | else |
---|
58 | CFLAGS="-pipe $RPM_OPT_FLAGS" ./configure \ |
---|
59 | --prefix=%{prefix} --sysconfdir=%{sysconfdir} \ |
---|
60 | --localstatedir=%{localstatedir} |
---|
61 | fi |
---|
62 | |
---|
63 | if [ "$SMP" != "" ]; then |
---|
64 | (make "MAKE=make -k -j $SMP"; exit 0) |
---|
65 | make |
---|
66 | else |
---|
67 | make |
---|
68 | fi |
---|
69 | |
---|
70 | %install |
---|
71 | rm -rf $RPM_BUILD_ROOT |
---|
72 | make install prefix=$RPM_BUILD_ROOT%{prefix} \ |
---|
73 | sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} \ |
---|
74 | localstatedir=$RPM_BUILD_ROOT%{localstatedir} |
---|
75 | |
---|
76 | %clean |
---|
77 | rm -rf $RPM_BUILD_ROOT |
---|
78 | |
---|
79 | %post -p /sbin/ldconfig |
---|
80 | |
---|
81 | %postun -p /sbin/ldconfig |
---|
82 | |
---|
83 | %files |
---|
84 | %defattr(-, root, root) |
---|
85 | %doc AUTHORS COPYING ChangeLog HACKING NEWS README THANKS TODO |
---|
86 | %{prefix}/bin/* |
---|
87 | %{prefix}/share/gnome/apps/* |
---|
88 | %{prefix}/share/pixmaps/* |
---|
89 | %{prefix}/share/locale/* |
---|
90 | %{prefix}/share/oaf/* |
---|
91 | %{prefix}/share/gnome/help/* |
---|
92 | %config /etc/CORBA/* |
---|