1 | %define release 6 |
---|
2 | %define prefix /usr |
---|
3 | %define name file-roller |
---|
4 | %define version 2.8.0 |
---|
5 | |
---|
6 | Summary: An archive manager for GNOME. |
---|
7 | Name: %{name} |
---|
8 | Version: %{version} |
---|
9 | Release: %{release} |
---|
10 | Copyright: GPL |
---|
11 | Vendor: GNOME |
---|
12 | URL: http://fileroller.sourceforge.net |
---|
13 | Group: Applications/Archiving |
---|
14 | Source0: %{name}-%{version}.tar.gz |
---|
15 | Packager: Paolo Bacchilega <paolo.bacch@tin.it> |
---|
16 | BuildRoot: %{_builddir}/%{name}-%{version}-root |
---|
17 | Requires: glib2 >= 2.0.0 |
---|
18 | Requires: gtk2 >= 2.1.0 |
---|
19 | Requires: libgnome >= 2.1.0 |
---|
20 | Requires: libgnomeui >= 2.1.0 |
---|
21 | Requires: gnome-vfs2 >= 2.1.3 |
---|
22 | Requires: libglade2 >= 2.0.0 |
---|
23 | Requires: bonobo-activation >= 1.0.0 |
---|
24 | Requires: libbonobo >= 2.0.0 |
---|
25 | Requires: libbonoboui >= 2.0.0 |
---|
26 | BuildRequires: glib2-devel >= 2.0.0 |
---|
27 | BuildRequires: gtk2-devel >= 2.1.0 |
---|
28 | BuildRequires: libgnome-devel >= 2.1.0 |
---|
29 | BuildRequires: libgnomeui-devel >= 2.1.0 |
---|
30 | BuildRequires: gnome-vfs2-devel >= 2.1.3 |
---|
31 | BuildRequires: libglade2-devel >= 2.0.0 |
---|
32 | BuildRequires: bonobo-activation-devel >= 1.0.0 |
---|
33 | BuildRequires: libbonobo-devel >= 2.0.0 |
---|
34 | BuildRequires: libbonoboui-devel >= 2.0.0 |
---|
35 | Docdir: %{prefix}/share/doc |
---|
36 | |
---|
37 | %description |
---|
38 | File Roller is an archive manager for the GNOME environment. This means that |
---|
39 | you can : create and modify archives; view the content of an archive; view a |
---|
40 | file contained in the archive; extract files from the archive. |
---|
41 | File Roller is only a front-end (a graphical interface) to archiving programs |
---|
42 | like tar and zip. The supported file types are : |
---|
43 | * Tar archives uncompressed (.tar) or compressed with |
---|
44 | * gzip (.tar.gz , .tgz) |
---|
45 | * bzip (.tar.bz , .tbz) |
---|
46 | * bzip2 (.tar.bz2 , .tbz2) |
---|
47 | * compress (.tar.Z , .taz) |
---|
48 | * lzop (.tar.lzo , .tzo) |
---|
49 | * Zip archives (.zip) |
---|
50 | * Jar archives (.jar , .ear , .war) |
---|
51 | * Lha archives (.lzh) |
---|
52 | * Rar archives (.rar) |
---|
53 | * Single files compressed with gzip, bzip, bzip2, compress, lzop |
---|
54 | |
---|
55 | %prep |
---|
56 | %setup |
---|
57 | |
---|
58 | %build |
---|
59 | %configure --disable-schemas-install |
---|
60 | make |
---|
61 | |
---|
62 | %install |
---|
63 | rm -rf $RPM_BUILD_ROOT |
---|
64 | make DESTDIR=$RPM_BUILD_ROOT install |
---|
65 | |
---|
66 | %clean |
---|
67 | rm -rf $RPM_BUILD_ROOT |
---|
68 | |
---|
69 | %files |
---|
70 | %defattr(-,root,root) |
---|
71 | %{_bindir}/file-roller |
---|
72 | %{_datadir}/applications/file-roller.desktop |
---|
73 | %{_datadir}/file-roller/glade/*.glade |
---|
74 | %{_datadir}/locale/*/LC_MESSAGES/file-roller.mo |
---|
75 | %{_datadir}/application-registry/file-roller.applications |
---|
76 | %{_datadir}/mime-info/* |
---|
77 | %{_datadir}/pixmaps/file-roller.png |
---|
78 | %{_libdir}/bonobo/*.a |
---|
79 | %{_libdir}/bonobo/*.la |
---|
80 | %{_libdir}/bonobo/*.so |
---|
81 | %{_libdir}/bonobo/servers/*.server |
---|
82 | %{_datadir}/omf/file-roller/*.omf |
---|
83 | %doc %{_datadir}/gnome/help/file-roller |
---|
84 | %doc AUTHORS NEWS README COPYING |
---|
85 | %config %{_sysconfdir}/gconf/schemas/* |
---|
86 | |
---|
87 | %post |
---|
88 | GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/file-roller.schemas |
---|
89 | if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update; fi |
---|
90 | |
---|
91 | %postun |
---|
92 | if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update; fi |
---|