source: trunk/third/gdk-pixbuf/gdk-pixbuf.spec @ 18121

Revision 18121, 2.6 KB checked in by ghudson, 22 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18120, which included commits to RCS files with non-trunk default branches.
Line 
1# Note that this is NOT a relocatable package
2%define name     gdk-pixbuf
3%define ver      0.22.0
4%define  RELEASE 1
5%define  rel     %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
6%define prefix   /usr
7
8Name: %name
9Summary: The GdkPixBuf image handling library
10Version: %ver
11Release: %rel
12Copyright: LGPL
13Group: System Environment/Libraries
14Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/%{name}-%{ver}.tar.gz
15URL: http://www.gnome.org/
16BuildRoot: /var/tmp/%{name}-root
17#Requires: gtk+ >= 1.2
18Docdir: %{prefix}/doc
19
20%description
21The GdkPixBuf library provides a number of features, including :
22
23- GdkPixbuf structure for representing images.
24- Image loading facilities.
25- Rendering of a GdkPixBuf into various formats:
26  drawables (windows, pixmaps), GdkRGB buffers.
27- Fast scaling and compositing of pixbufs.
28- Simple animation loading (ie. animated gifs)
29
30In addition, this module also provides a little libgnomecanvaspixbuf
31library, which contains a GNOME Canvas item to display pixbufs with
32full affine transformations.
33
34%package devel
35Summary: Libraries and include files for developing GdkPixBuf applications.
36Group: Development/Libraries
37#Requires: %name = %{PACKAGE_VERSION}
38#Obsoletes: %name-devel
39
40%description devel
41Libraries and include files for developing GdkPixBuf applications.
42
43%changelog
44* Sat Jan 22 2000 Ross Golder <rossigee@bigfoot.com>
45
46- Borrowed from gnome-libs to integrate into gdk-pixbuf source tree
47
48%prep
49%setup -q
50
51%build
52%ifarch alpha
53 MYARCH_FLAGS="--host=alpha-redhat-linux"
54%endif
55# Needed for snapshot releases.
56
57MYCFLAGS="$RPM_OPT_FLAGS"
58
59if [ ! -f configure ]; then
60  CFLAGS="$MYCFLAGS" ./autogen.sh $MYARCH_FLAGS --prefix=%prefix --localstatedir=/var/lib --sysconfdir=/etc
61else
62  CFLAGS="$MYCFLAGS" ./configure $MYARCH_FLAGS --prefix=%prefix --localstatedir=/var/lib --sysconfdir=/etc
63fi
64
65if [ "$SMP" != "" ]; then
66  make -j$SMP "MAKE=make -j$SMP"
67else
68  make
69fi
70
71%install
72rm -rf $RPM_BUILD_ROOT
73
74make sysconfdir=$RPM_BUILD_ROOT/etc prefix=$RPM_BUILD_ROOT%{prefix} install
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post
80if ! grep %{prefix}/lib /etc/ld.so.conf > /dev/null ; then
81  echo "%{prefix}/lib" >> /etc/ld.so.conf
82fi
83
84/sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(-, root, root)
90
91%doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README TODO doc/*.txt html
92%{prefix}/lib/lib*.so.*
93%{prefix}/lib/%{name}/loaders/lib*.so*
94
95%files devel
96%defattr(-, root, root)
97
98#%doc HACKING MAINTAINERS
99%{prefix}/bin/*
100%{prefix}/lib/lib*.so
101%{prefix}/lib/%{name}/loaders/lib*.a
102%{prefix}/lib/*.a
103%{prefix}/lib/*.sh
104%{prefix}/include/*
105%{prefix}/share/aclocal/*
106%{prefix}/share/gnome/html/*
107
108
Note: See TracBrowser for help on using the repository browser.