1 | # Note that this is NOT a relocatable package |
---|
2 | %define name gdk-pixbuf |
---|
3 | %define ver 0.22.0 |
---|
4 | %define RELEASE 1 |
---|
5 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
6 | %define prefix /usr |
---|
7 | |
---|
8 | Name: %name |
---|
9 | Summary: The GdkPixBuf image handling library |
---|
10 | Version: %ver |
---|
11 | Release: %rel |
---|
12 | Copyright: LGPL |
---|
13 | Group: System Environment/Libraries |
---|
14 | Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/%{name}-%{ver}.tar.gz |
---|
15 | URL: http://www.gnome.org/ |
---|
16 | BuildRoot: /var/tmp/%{name}-root |
---|
17 | #Requires: gtk+ >= 1.2 |
---|
18 | Docdir: %{prefix}/doc |
---|
19 | |
---|
20 | %description |
---|
21 | The GdkPixBuf library provides a number of features, including : |
---|
22 | |
---|
23 | - GdkPixbuf structure for representing images. |
---|
24 | - Image loading facilities. |
---|
25 | - Rendering of a GdkPixBuf into various formats: |
---|
26 | drawables (windows, pixmaps), GdkRGB buffers. |
---|
27 | - Fast scaling and compositing of pixbufs. |
---|
28 | - Simple animation loading (ie. animated gifs) |
---|
29 | |
---|
30 | In addition, this module also provides a little libgnomecanvaspixbuf |
---|
31 | library, which contains a GNOME Canvas item to display pixbufs with |
---|
32 | full affine transformations. |
---|
33 | |
---|
34 | %package devel |
---|
35 | Summary: Libraries and include files for developing GdkPixBuf applications. |
---|
36 | Group: Development/Libraries |
---|
37 | #Requires: %name = %{PACKAGE_VERSION} |
---|
38 | #Obsoletes: %name-devel |
---|
39 | |
---|
40 | %description devel |
---|
41 | Libraries and include files for developing GdkPixBuf applications. |
---|
42 | |
---|
43 | %changelog |
---|
44 | * Sat Jan 22 2000 Ross Golder <rossigee@bigfoot.com> |
---|
45 | |
---|
46 | - Borrowed from gnome-libs to integrate into gdk-pixbuf source tree |
---|
47 | |
---|
48 | %prep |
---|
49 | %setup -q |
---|
50 | |
---|
51 | %build |
---|
52 | %ifarch alpha |
---|
53 | MYARCH_FLAGS="--host=alpha-redhat-linux" |
---|
54 | %endif |
---|
55 | # Needed for snapshot releases. |
---|
56 | |
---|
57 | MYCFLAGS="$RPM_OPT_FLAGS" |
---|
58 | |
---|
59 | if [ ! -f configure ]; then |
---|
60 | CFLAGS="$MYCFLAGS" ./autogen.sh $MYARCH_FLAGS --prefix=%prefix --localstatedir=/var/lib --sysconfdir=/etc |
---|
61 | else |
---|
62 | CFLAGS="$MYCFLAGS" ./configure $MYARCH_FLAGS --prefix=%prefix --localstatedir=/var/lib --sysconfdir=/etc |
---|
63 | fi |
---|
64 | |
---|
65 | if [ "$SMP" != "" ]; then |
---|
66 | make -j$SMP "MAKE=make -j$SMP" |
---|
67 | else |
---|
68 | make |
---|
69 | fi |
---|
70 | |
---|
71 | %install |
---|
72 | rm -rf $RPM_BUILD_ROOT |
---|
73 | |
---|
74 | make sysconfdir=$RPM_BUILD_ROOT/etc prefix=$RPM_BUILD_ROOT%{prefix} install |
---|
75 | |
---|
76 | %clean |
---|
77 | rm -rf $RPM_BUILD_ROOT |
---|
78 | |
---|
79 | %post |
---|
80 | if ! grep %{prefix}/lib /etc/ld.so.conf > /dev/null ; then |
---|
81 | echo "%{prefix}/lib" >> /etc/ld.so.conf |
---|
82 | fi |
---|
83 | |
---|
84 | /sbin/ldconfig |
---|
85 | |
---|
86 | %postun -p /sbin/ldconfig |
---|
87 | |
---|
88 | %files |
---|
89 | %defattr(-, root, root) |
---|
90 | |
---|
91 | %doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README TODO doc/*.txt html |
---|
92 | %{prefix}/lib/lib*.so.* |
---|
93 | %{prefix}/lib/%{name}/loaders/lib*.so* |
---|
94 | |
---|
95 | %files devel |
---|
96 | %defattr(-, root, root) |
---|
97 | |
---|
98 | #%doc HACKING MAINTAINERS |
---|
99 | %{prefix}/bin/* |
---|
100 | %{prefix}/lib/lib*.so |
---|
101 | %{prefix}/lib/%{name}/loaders/lib*.a |
---|
102 | %{prefix}/lib/*.a |
---|
103 | %{prefix}/lib/*.sh |
---|
104 | %{prefix}/include/* |
---|
105 | %{prefix}/share/aclocal/* |
---|
106 | %{prefix}/share/gnome/html/* |
---|
107 | |
---|
108 | |
---|