1 | # Note that this is NOT a relocatable package |
---|
2 | # defaults for redhat |
---|
3 | %define prefix /usr |
---|
4 | %define sysconfdir /etc |
---|
5 | |
---|
6 | %define RELEASE 1 |
---|
7 | %define rel %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE} |
---|
8 | |
---|
9 | Summary: GNOME PostScript viewer |
---|
10 | Name: ggv |
---|
11 | Version: 1.99.98 |
---|
12 | Release: %rel |
---|
13 | Copyright: GPL |
---|
14 | Group: X11/Utilities |
---|
15 | Source: ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/%{name}-%{version}.tar.gz |
---|
16 | BuildRoot: /var/tmp/%{name}-%{version}-root |
---|
17 | URL: http://www.gnome.org/ |
---|
18 | DocDir: %{prefix}/doc |
---|
19 | |
---|
20 | %description |
---|
21 | ggv allows you to view PostScript documents, and print ranges |
---|
22 | of pages. |
---|
23 | |
---|
24 | %changelog |
---|
25 | * Fri Aug 27 1999 Karl Eichwalder <ke@suse.de> |
---|
26 | - Added more %doc files |
---|
27 | - Fixed the spelling of PostScript and the Source entry |
---|
28 | |
---|
29 | * Sat Aug 21 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org> |
---|
30 | - Actualized spec file |
---|
31 | |
---|
32 | * Thu Aug 13 1998 Marc Ewing <marc@redhat.com> |
---|
33 | - Initial spec file copied from gnome-graphics |
---|
34 | |
---|
35 | %prep |
---|
36 | %setup |
---|
37 | |
---|
38 | %build |
---|
39 | |
---|
40 | # libtool workaround for alphalinux |
---|
41 | %ifarch alpha |
---|
42 | ARCH_FLAGS="--host=alpha-redhat-linux" |
---|
43 | %endif |
---|
44 | |
---|
45 | # Needed for snapshot releases. |
---|
46 | if [ ! -f configure ]; then |
---|
47 | CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir} --disable-install-schemas |
---|
48 | else |
---|
49 | CFLAGS="$RPM_OPT_FLAGS" ./configure $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir} --disable-install-schemas |
---|
50 | fi |
---|
51 | |
---|
52 | if [ "$SMP" != "" ]; then |
---|
53 | (make "MAKE=make -k -j $SMP"; exit 0) |
---|
54 | make |
---|
55 | else |
---|
56 | make |
---|
57 | fi |
---|
58 | |
---|
59 | %install |
---|
60 | rm -rf $RPM_BUILD_ROOT |
---|
61 | |
---|
62 | make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install |
---|
63 | |
---|
64 | %clean |
---|
65 | rm -rf $RPM_BUILD_ROOT |
---|
66 | |
---|
67 | %files |
---|
68 | %defattr(-, root, root) |
---|
69 | |
---|
70 | %doc AUTHORS BUGS COPYING ChangeLog MAINTAINERS NEWS README TODO |
---|
71 | %{_bindir}/* |
---|
72 | %{_datadir}/bin/* |
---|
73 | %config %{_sysconfdir}/* |
---|
74 | |
---|
75 | %post |
---|
76 | SOURCE=xml::%{sysconfdir}/gconf/gconf.xml.defaults |
---|
77 | GCONF_CONFIG_SOURCE=$SOURCE gconftool --makefile-install-rule %{sysconfdir}/gconf/schemas/ggv.schemas 2>/dev/null >/dev/null |
---|
78 | if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update; fi |
---|
79 | |
---|
80 | %postun |
---|
81 | if which scrollkeeper-update>/dev/null 2>&1; then scrollkeeper-update; fi |
---|
82 | |
---|